aboutsummaryrefslogtreecommitdiff
path: root/python/python3-putio.py/python3-putio.py.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-putio.py/python3-putio.py.SlackBuild')
-rw-r--r--python/python3-putio.py/python3-putio.py.SlackBuild37
1 files changed, 17 insertions, 20 deletions
diff --git a/python/python3-putio.py/python3-putio.py.SlackBuild b/python/python3-putio.py/python3-putio.py.SlackBuild
index 88e4b56767..35c4ca0772 100644
--- a/python/python3-putio.py/python3-putio.py.SlackBuild
+++ b/python/python3-putio.py/python3-putio.py.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-putio.py
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2025 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-putio.py
SRCNAM=putio.py
-VERSION=${VERSION:-8.7.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-8.8.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -47,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,10 +62,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix building from source
-sed -i "s/'0'/\'$VERSION\'/" setup.py
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true