aboutsummaryrefslogtreecommitdiff
path: root/python/python3-pdm/python3-pdm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pdm/python3-pdm.SlackBuild')
-rw-r--r--python/python3-pdm/python3-pdm.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/python3-pdm/python3-pdm.SlackBuild b/python/python3-pdm/python3-pdm.SlackBuild
index 3c76609d0c..30fc271265 100644
--- a/python/python3-pdm/python3-pdm.SlackBuild
+++ b/python/python3-pdm/python3-pdm.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-pdm
-# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2025 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pdm
-VERSION=${VERSION:-2.19.1}
+VERSION=${VERSION:-2.22.4}
SRCNAM=${SRCNAM:-pdm}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,6 +65,9 @@ find -L . \
# Remove unused dependency (used for redistributable builds of python)
sed -i '/\"pbs-installer.*\",/d' pyproject.toml
+# Remove hard version requirement on certifi, since it's been working fine
+sed -i 's|certifi.*|certifi",|' pyproject.toml
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl