aboutsummaryrefslogtreecommitdiff
path: root/python/python3-klein
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-klein')
-rw-r--r--python/python3-klein/python3-klein.SlackBuild9
-rw-r--r--python/python3-klein/python3-klein.info6
2 files changed, 10 insertions, 5 deletions
diff --git a/python/python3-klein/python3-klein.SlackBuild b/python/python3-klein/python3-klein.SlackBuild
index 64d1c5f03a..0db6699afb 100644
--- a/python/python3-klein/python3-klein.SlackBuild
+++ b/python/python3-klein/python3-klein.SlackBuild
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-klein
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-23.12.0}
+VERSION=${VERSION:-24.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH="/opt/python$PYVER/site-packages"
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+# python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-klein/python3-klein.info b/python/python3-klein/python3-klein.info
index a6c26651e6..9963cb434f 100644
--- a/python/python3-klein/python3-klein.info
+++ b/python/python3-klein/python3-klein.info
@@ -1,8 +1,8 @@
PRGNAM="python3-klein"
-VERSION="23.12.0"
+VERSION="24.8.0"
HOMEPAGE="https://klein.readthedocs.io/"
-DOWNLOAD="https://pypi.python.org/packages/source/k/klein/klein-23.12.0.tar.gz"
-MD5SUM="f51f89b1ec0cb90d3793fc855de856c9"
+DOWNLOAD="https://pypi.python.org/packages/source/k/klein/klein-24.8.0.tar.gz"
+MD5SUM="03aae172aa0c84d5499e091b1ba71547"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-tubes werkzeug"