aboutsummaryrefslogtreecommitdiff
path: root/python/python3-json-logger
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-json-logger')
-rw-r--r--python/python3-json-logger/python3-json-logger.SlackBuild26
-rw-r--r--python/python3-json-logger/python3-json-logger.info10
2 files changed, 13 insertions, 23 deletions
diff --git a/python/python3-json-logger/python3-json-logger.SlackBuild b/python/python3-json-logger/python3-json-logger.SlackBuild
index 5ee663f1a2..7278abb537 100644
--- a/python/python3-json-logger/python3-json-logger.SlackBuild
+++ b/python/python3-json-logger/python3-json-logger.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-json-logger
-# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-json-logger
-VERSION=${VERSION:-2.0.7}
+VERSION=${VERSION:-3.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -78,13 +64,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/changelog.md docs/contributing.md README.md docs/security.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-json-logger/python3-json-logger.info b/python/python3-json-logger/python3-json-logger.info
index 1dc89d1e70..64947858ad 100644
--- a/python/python3-json-logger/python3-json-logger.info
+++ b/python/python3-json-logger/python3-json-logger.info
@@ -1,10 +1,10 @@
PRGNAM="python3-json-logger"
-VERSION="2.0.7"
-HOMEPAGE="https://github.com/madzak/python-json-logger"
-DOWNLOAD="https://github.com/madzak/python-json-logger/archive/v2.0.7/python-json-logger-2.0.7.tar.gz"
-MD5SUM="280d601aa6fad91cc0f1bf67e44522ab"
+VERSION="3.2.1"
+HOMEPAGE="https://github.com/nhairs/python-json-logger"
+DOWNLOAD="https://github.com/nhairs/python-json-logger/archive/v3.2.1/python-json-logger-3.2.1.tar.gz"
+MD5SUM="dd57f9cfeb7af11394b9522875a166ee"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt python3-typing-extensions"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"