aboutsummaryrefslogtreecommitdiff
path: root/python/python3-incremental
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-incremental')
-rw-r--r--python/python3-incremental/README6
-rw-r--r--python/python3-incremental/python3-incremental.SlackBuild13
-rw-r--r--python/python3-incremental/python3-incremental.info8
3 files changed, 20 insertions, 7 deletions
diff --git a/python/python3-incremental/README b/python/python3-incremental/README
index 799a08d258..9033ee5102 100644
--- a/python/python3-incremental/README
+++ b/python/python3-incremental/README
@@ -1 +1,7 @@
Incremental is a small library that versions your Python projects.
+
+Beware, since 24.7 release, this packages interferes with some*
+other builds, which were fine with stock setuptools.
+You can either remove python3-incremental before building, or
+export PYTHONPATH=/opt/python$PYVER/site-packages
+with PYVER set to your python3 version.
diff --git a/python/python3-incremental/python3-incremental.SlackBuild b/python/python3-incremental/python3-incremental.SlackBuild
index 06c1f3d75a..ddb79d03b7 100644
--- a/python/python3-incremental/python3-incremental.SlackBuild
+++ b/python/python3-incremental/python3-incremental.SlackBuild
@@ -26,8 +26,8 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-incremental
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-22.10.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-24.7.2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,7 +63,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+
+# Prevent incremental from messing up Slackware setuptools
+sed -i '/\[setuptools.fin/,/^incremental /d' $PKG/usr/lib*/python$PYVER/site-packages/incremental-$VERSION.dist-info/entry_points.txt
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-incremental/python3-incremental.info b/python/python3-incremental/python3-incremental.info
index 792a0fa135..1ec36c42d5 100644
--- a/python/python3-incremental/python3-incremental.info
+++ b/python/python3-incremental/python3-incremental.info
@@ -1,10 +1,10 @@
PRGNAM="python3-incremental"
-VERSION="22.10.0"
+VERSION="24.7.2"
HOMEPAGE="https://pypi.org/project/incremental/"
-DOWNLOAD="https://pypi.python.org/packages/source/i/incremental/incremental-22.10.0.tar.gz"
-MD5SUM="9fffa2490ca649550c79a78e85ef2eef"
+DOWNLOAD="https://pypi.python.org/packages/source/i/incremental/incremental-24.7.2.tar.gz"
+MD5SUM="d946fb1a369c77693b4dab8ac9b13596"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-tomli-opt python3-setuptools-opt"
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"