aboutsummaryrefslogtreecommitdiff
path: root/python/python3-httpx/python3-httpx.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-httpx/python3-httpx.SlackBuild')
-rw-r--r--python/python3-httpx/python3-httpx.SlackBuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/python/python3-httpx/python3-httpx.SlackBuild b/python/python3-httpx/python3-httpx.SlackBuild
index 9c54101cb3..489ce8e790 100644
--- a/python/python3-httpx/python3-httpx.SlackBuild
+++ b/python/python3-httpx/python3-httpx.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-httpx
-# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2025 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-httpx
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-0.23.3}
+VERSION=${VERSION:-0.28.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -69,10 +69,6 @@ find -L . \
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages
-#remove upper version requirement from pyproject.toml and PKG-INFO
-/usr/bin/sed -i 's/,<[0-9].*\",$/\",/' pyproject.toml
-/usr/bin/sed -i 's/<[0-9].*,//' PKG-INFO
-
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl