aboutsummaryrefslogtreecommitdiff
path: root/python/python3-grpcio/python3-grpcio.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-grpcio/python3-grpcio.SlackBuild')
-rw-r--r--python/python3-grpcio/python3-grpcio.SlackBuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/python/python3-grpcio/python3-grpcio.SlackBuild b/python/python3-grpcio/python3-grpcio.SlackBuild
index 44653bb8b9..ee82179fd3 100644
--- a/python/python3-grpcio/python3-grpcio.SlackBuild
+++ b/python/python3-grpcio/python3-grpcio.SlackBuild
@@ -16,7 +16,7 @@
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
@@ -25,12 +25,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-grpcio
-VERSION=${VERSION:-1.67.1}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.71.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=grpc
+PROTOVER=${PROTOVER:-30.1}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -57,6 +58,13 @@ cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
+
+# Extract protobuf tarball
+tar xvf $CWD/protobuf-$PROTOVER.tar.gz
+cd protobuf-$PROTOVER
+patch -p1 < $CWD/protobuf-reenable-private-headers.patch
+cd ..
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -87,9 +95,9 @@ sed -r -i \
tools/distrib/python/grpcio_tools/protoc_lib_deps.py
ln -s ../../../.. tools/distrib/python/grpcio_tools/grpc_root
-# Build python3-grcpio_tools
+# Build python3-grcpio-tools
cd tools/distrib/python/grpcio_tools
-GRPC_PYTHON_CFLAGS="-fno-wrapv -frtti $(pkg-config --cflags protobuf)" \
+GRPC_PYTHON_CFLAGS="-fno-wrapv -frtti $(pkg-config --cflags protobuf) -I$TMP/$SRCNAM-$VERSION/protobuf-$PROTOVER/src" \
GRPC_PYTHON_LDFLAGS="$(pkg-config --libs protobuf) -lprotoc" \
python3 setup.py install --root=$PKG
cd $TMP/$SRCNAM-$VERSION