aboutsummaryrefslogtreecommitdiff
path: root/python/python3-gearbox/python3-gearbox.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-gearbox/python3-gearbox.SlackBuild')
-rw-r--r--python/python3-gearbox/python3-gearbox.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/python3-gearbox/python3-gearbox.SlackBuild b/python/python3-gearbox/python3-gearbox.SlackBuild
index db5d15167c..a2773cf68e 100644
--- a/python/python3-gearbox/python3-gearbox.SlackBuild
+++ b/python/python3-gearbox/python3-gearbox.SlackBuild
@@ -24,7 +24,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-gearbox
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-0.2.2}
+VERSION=${VERSION:-0.3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -64,7 +64,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README* MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION