aboutsummaryrefslogtreecommitdiff
path: root/python/python3-falcon/python3-falcon.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-falcon/python3-falcon.SlackBuild')
-rw-r--r--python/python3-falcon/python3-falcon.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/python3-falcon/python3-falcon.SlackBuild b/python/python3-falcon/python3-falcon.SlackBuild
index 58c091f848..5c8c1dbe34 100644
--- a/python/python3-falcon/python3-falcon.SlackBuild
+++ b/python/python3-falcon/python3-falcon.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-falcon
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-3.1.3}
+VERSION=${VERSION:-4.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -59,7 +59,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH="/opt/python$PYVER/site-packages:/opt/cython/python$PYVER/site-packages"
+export PATH="/opt/cython/bin:$PATH"
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true