aboutsummaryrefslogtreecommitdiff
path: root/python/python3-diff-match-patch/python3-diff-match-patch.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-diff-match-patch/python3-diff-match-patch.SlackBuild')
-rw-r--r--python/python3-diff-match-patch/python3-diff-match-patch.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/python3-diff-match-patch/python3-diff-match-patch.SlackBuild b/python/python3-diff-match-patch/python3-diff-match-patch.SlackBuild
index d660cf4b64..cb2168c232 100644
--- a/python/python3-diff-match-patch/python3-diff-match-patch.SlackBuild
+++ b/python/python3-diff-match-patch/python3-diff-match-patch.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-diff-match-patch
-VERSION=${VERSION:-20200713}
+VERSION=${VERSION:-20230430}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,13 +78,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CODE_OF_CONDUCT.md CONTRIBUTING.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install