aboutsummaryrefslogtreecommitdiff
path: root/python/python3-automat/python3-automat.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-automat/python3-automat.SlackBuild')
-rw-r--r--python/python3-automat/python3-automat.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/python/python3-automat/python3-automat.SlackBuild b/python/python3-automat/python3-automat.SlackBuild
index b170f1232b..d5c758a27d 100644
--- a/python/python3-automat/python3-automat.SlackBuild
+++ b/python/python3-automat/python3-automat.SlackBuild
@@ -27,8 +27,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-automat
-SRCNAM=Automat
-VERSION=${VERSION:-22.10.0}
+SRCNAM=automat
+VERSION=${VERSION:-24.8.1}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -86,7 +86,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true