aboutsummaryrefslogtreecommitdiff
path: root/python/python2-netaddr
diff options
context:
space:
mode:
Diffstat (limited to 'python/python2-netaddr')
-rw-r--r--python/python2-netaddr/README20
-rw-r--r--python/python2-netaddr/python2-netaddr.SlackBuild97
-rw-r--r--python/python2-netaddr/python2-netaddr.info10
-rw-r--r--python/python2-netaddr/slack-desc19
4 files changed, 0 insertions, 146 deletions
diff --git a/python/python2-netaddr/README b/python/python2-netaddr/README
deleted file mode 100644
index 686ffe012c..0000000000
--- a/python/python2-netaddr/README
+++ /dev/null
@@ -1,20 +0,0 @@
-A pure Python network address representation and manipulation library.
-
-netaddr provides a Pythonic way of working with :-
-- IPv4 and IPv6 addresses and subnets
-- MAC addresses, OUI and IAB identifiers, IEEE EUI-64 identifiers
-- arbitrary (non-aligned) IP address ranges and IP address sets
-- various non-CIDR IP range formats such as nmap and glob-style formats
-
-The source package includes (probably now out of date) data from:
-1. http://standards.ieee.org (public OUI and IAB registration data
-published by the IEEE)
-2. http://www.iana.org (IPv4, IPv6 and multicast address space
-allocations).
-
-To include the latest versions in the package, run the script with:
-
-# NEWDATA="yes" ./python-netaddr.SlackBuild
-
-and the latest versions will be downloaded during the build
-for inclusion in the package.
diff --git a/python/python2-netaddr/python2-netaddr.SlackBuild b/python/python2-netaddr/python2-netaddr.SlackBuild
deleted file mode 100644
index 757793263f..0000000000
--- a/python/python2-netaddr/python2-netaddr.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-netaddr
-
-# Copyright 2013-2024 Christoph Willing, Sydney Australia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python2-netaddr
-SRC_PRGNAM=netaddr
-VERSION=${VERSION:-0.10.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -ev
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRC_PRGNAM-$VERSION
-tar xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
-cd $SRC_PRGNAM-$VERSION
-
-if [ ${NEWDATA:-no} = "yes" ]; then
- echo 'downloading latest IEEE data'
- (cd netaddr/eui/ && wget -N http://standards.ieee.org/regauth/oui/oui.txt)
- (cd netaddr/eui/ && wget -N http://standards.ieee.org/regauth/oui/iab.txt)
- echo 'rebuilding IEEE data file indices'
- PYTHONPATH="." python netaddr/eui/ieee.py
- echo 'downloading latest IANA data'
- (cd netaddr/ip/ && wget -N http://www.iana.org/assignments/ipv4-address-space/ipv4-address-space.xml)
- (cd netaddr/ip/ && wget -N http://www.iana.org/assignments/ipv6-address-space/ipv6-address-space.xml)
- (cd netaddr/ip/ && wget -N http://www.iana.org/assignments/multicast-addresses/multicast-addresses.xml)
-fi
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs/* \
- AUTHORS CHANGELOG COPYRIGHT LICENSE README* THANKS \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-netaddr/python2-netaddr.info b/python/python2-netaddr/python2-netaddr.info
deleted file mode 100644
index dd06259182..0000000000
--- a/python/python2-netaddr/python2-netaddr.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python2-netaddr"
-VERSION="0.10.1"
-HOMEPAGE="https://github.com/netaddr/netaddr"
-DOWNLOAD="https://github.com/netaddr/netaddr/archive/refs/tags/0.10.1/netaddr-0.10.1.tar.gz"
-MD5SUM="02ce5aa8af8699d1f0243d74c7535fd2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Christoph Willing"
-EMAIL="chris.willing@linux.com"
diff --git a/python/python2-netaddr/slack-desc b/python/python2-netaddr/slack-desc
deleted file mode 100644
index fa83a05f7f..0000000000
--- a/python/python2-netaddr/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python2-netaddr: python2-netaddr (Network address manipulation)
-python2-netaddr:
-python2-netaddr: netaddr provides a Pythonic way of working with:
-python2-netaddr: - IPv4 and IPv6 addresses and subnets
-python2-netaddr: - MAC addresses, OUI and IAB identifiers, IEEE EUI-64 identifiers
-python2-netaddr: - arbitrary (non-aligned) IP address ranges and IP address sets
-python2-netaddr: - some non-CIDR IP range formats such as nmap and glob-style formats
-python2-netaddr:
-python2-netaddr: nettaddr is able to manipulate IPv4, IPv6, CIDR, EUI and MAC
-python2-netaddr: network addresses.
-python2-netaddr: