aboutsummaryrefslogtreecommitdiff
path: root/python/python2-cryptography/python2-cryptography.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python2-cryptography/python2-cryptography.SlackBuild')
-rw-r--r--python/python2-cryptography/python2-cryptography.SlackBuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/python/python2-cryptography/python2-cryptography.SlackBuild b/python/python2-cryptography/python2-cryptography.SlackBuild
index da280bd7d2..ece09ec3e5 100644
--- a/python/python2-cryptography/python2-cryptography.SlackBuild
+++ b/python/python2-cryptography/python2-cryptography.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python2-cryptography
SRCNAM=cryptography
VERSION=${VERSION:-3.3.2}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,6 +78,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+export CFLAGS="$SLKCFLAGS -fpermissive"
python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \