aboutsummaryrefslogtreecommitdiff
path: root/python/python-libtmux/python-libtmux.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-libtmux/python-libtmux.SlackBuild')
-rw-r--r--python/python-libtmux/python-libtmux.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/python-libtmux/python-libtmux.SlackBuild b/python/python-libtmux/python-libtmux.SlackBuild
index 1eb3e54253..8c4ac72e4a 100644
--- a/python/python-libtmux/python-libtmux.SlackBuild
+++ b/python/python-libtmux/python-libtmux.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-libtmux
-# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2020 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-libtmux
SRCNAM=$(echo $PRGNAM | cut -c8-14)
-VERSION=${VERSION:-0.8.2}
+VERSION=${VERSION:-0.8.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true