aboutsummaryrefslogtreecommitdiff
path: root/python/python-django-legacy
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-django-legacy')
-rw-r--r--python/python-django-legacy/README10
-rw-r--r--python/python-django-legacy/python-django-legacy.SlackBuild88
-rw-r--r--python/python-django-legacy/python-django-legacy.info10
-rw-r--r--python/python-django-legacy/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/python/python-django-legacy/README b/python/python-django-legacy/README
deleted file mode 100644
index 3bb9d16c4c..0000000000
--- a/python/python-django-legacy/README
+++ /dev/null
@@ -1,10 +0,0 @@
-python-django-legacy (The Web framework for perfectionists with deadlines)
-
-Django is a high-level Python Web framework that encourages rapid development
-and clean, pragmatic design.
-
-
-IMPORTANT
-
-This package conflicts with python-django. python-django-legacy and
-python-django cannot both be installed at the same time.
diff --git a/python/python-django-legacy/python-django-legacy.SlackBuild b/python/python-django-legacy/python-django-legacy.SlackBuild
deleted file mode 100644
index 1c20814f23..0000000000
--- a/python/python-django-legacy/python-django-legacy.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-django-legacy
-
-# Copyright 2015, 2016 Mario Preksavec, Zagreb, Croatia
-# All rights reserved.
-#
-# This version has the version number changed, by David Melikm, Spokane, WA
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Maintained by David Melik <dchmelik@gmail.com>
-
-PRGNAM=python-django-legacy
-SRCNAM=django
-VERSION=${VERSION:-1.8.17}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG --prefix=/usr
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CONTRIBUTING.rst INSTALL LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-django-legacy/python-django-legacy.info b/python/python-django-legacy/python-django-legacy.info
deleted file mode 100644
index 00a3de75ce..0000000000
--- a/python/python-django-legacy/python-django-legacy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-django-legacy"
-VERSION="1.8.17"
-HOMEPAGE="https://github.com/django/"
-DOWNLOAD="https://github.com/django/django/archive/1.8.17/django-1.8.17.tar.gz"
-MD5SUM="685b01ff237670427dca72c7f9d5fe56"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="David Melik"
-EMAIL="dchmelik@gmail.com"
diff --git a/python/python-django-legacy/slack-desc b/python/python-django-legacy/slack-desc
deleted file mode 100644
index 5414158186..0000000000
--- a/python/python-django-legacy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-django-legacy: python-django-legacy (Web framework)
-python-django-legacy:
-python-django-legacy: Django is a high-level Python Web framework that encourages
-python-django-legacy: rapid development and clean, pragmatic design.
-python-django-legacy:
-python-django-legacy: Homepage: https://github.com/django/
-python-django-legacy:
-python-django-legacy:
-python-django-legacy:
-python-django-legacy:
-python-django-legacy: