aboutsummaryrefslogtreecommitdiff
path: root/python/python-debian/python-debian.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-debian/python-debian.SlackBuild')
-rw-r--r--python/python-debian/python-debian.SlackBuild22
1 files changed, 18 insertions, 4 deletions
diff --git a/python/python-debian/python-debian.SlackBuild b/python/python-debian/python-debian.SlackBuild
index 87e5480dfc..05b1e3d67e 100644
--- a/python/python-debian/python-debian.SlackBuild
+++ b/python/python-debian/python-debian.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-debian
-# Copyright 2022-2023 Vijay Marcel
+# Copyright 2022-2025 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,21 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Changelog for python-debian SlackBuild Script
+# --------------------------------------------------------------------------------
+
+# 05/11/2022: Added to slackbuilds.org
+# 26/11/2022: gitlab tarball handling fixed by Andrew Clemons
+# 17/05/2023: Updated to version 0.1.49
+# 19/02/2025: Updated to version 0.1.52
+
+# ----------------------------------------------------------------------------------
+
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-debian
-VERSION=${VERSION:-0.1.49}
+VERSION=${VERSION:-0.1.52}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,10 +92,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs examples debian README.rst $PKG/usr/doc/$PRGNAM-$VERSION