aboutsummaryrefslogtreecommitdiff
path: root/python/python-configargparse/python-configargparse.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-configargparse/python-configargparse.SlackBuild')
-rw-r--r--python/python-configargparse/python-configargparse.SlackBuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/python/python-configargparse/python-configargparse.SlackBuild b/python/python-configargparse/python-configargparse.SlackBuild
index 3ec4d1c6ce..5775391081 100644
--- a/python/python-configargparse/python-configargparse.SlackBuild
+++ b/python/python-configargparse/python-configargparse.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-configargparse
-# Copyright 2015-2020 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-configargparse
SRCNAM=ConfigArgParse
-VERSION=${VERSION:-1.2.3}
+VERSION=${VERSION:-1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,11 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true