aboutsummaryrefslogtreecommitdiff
path: root/python/pygsl/pygsl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pygsl/pygsl.SlackBuild')
-rw-r--r--python/pygsl/pygsl.SlackBuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/python/pygsl/pygsl.SlackBuild b/python/pygsl/pygsl.SlackBuild
index 6d87916a68..cd88438355 100644
--- a/python/pygsl/pygsl.SlackBuild
+++ b/python/pygsl/pygsl.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for PyGSL
# Based on the Slackware 15.0 SlackBuild
#
-# Copyright 2017-2023, Fellype do Nascimento, Guaratinguetá - Brazil
+# Copyright 2017-2025, Fellype do Nascimento, Guaratinguetá - Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pygsl
-VERSION=${VERSION:-2.3.3}
+VERSION=${VERSION:-2.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,13 +80,25 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+python3 setup.py gsl_wrappers
python3 setup.py config
python3 setup.py build
-python3 setup.py install --root=$PKG --prefix=/usr
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# I am not sure if the build produces these "UNKNOWN" folders in all systems
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+if [ -d $PKG/usr/include/python$PYVER/UNKNOWN ]; then
+ mkdir -p $PKG/usr/include/python$PYVER/$PRGNAM
+ mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/python$PYVER/site-packages/$PRGNAM-$VERSION-py$PYVER.egg-info
+ mv $PKG/usr/include/python$PYVER/UNKNOWN/* $PKG/usr/include/python$PYVER/$PRGNAM
+ mv $PKG/usr/lib$LIBDIRSUFFIX/python$PYVER/site-packages/UNKNOWN-0.0.0-py$PYVER.egg-info/* $PKG/usr/lib$LIBDIRSUFFIX/python$PYVER/site-packages/$PRGNAM-$VERSION-py$PYVER.egg-info
+ rmdir $PKG/usr/include/python$PYVER/UNKNOWN
+ rmdir $PKG/usr/lib$LIBDIRSUFFIX/python$PYVER/site-packages/UNKNOWN-0.0.0-py$PYVER.egg-info
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
ChangeLog COPYING CREDITS.rst README.rst TODO.rst \