aboutsummaryrefslogtreecommitdiff
path: root/python/mypy/mypy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/mypy/mypy.SlackBuild')
-rw-r--r--python/mypy/mypy.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/python/mypy/mypy.SlackBuild b/python/mypy/mypy.SlackBuild
index 6964cfc939..51d7a984e7 100644
--- a/python/mypy/mypy.SlackBuild
+++ b/python/mypy/mypy.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for mypy
# Written by Tim Dickson dickson.tim@googlemail.com
-# Copyright (c) 2018-24 Tim Dickson, Scotland
+# Copyright (c) 2018-25 Tim Dickson, Scotland
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mypy
-VERSION=${VERSION:-1.13.0}
+VERSION=${VERSION:-1.14.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,7 +83,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+python3 -m build --no-isolation --skip-dependency-check
+python3 -m installer -d "$PKG" dist/*.whl
+#python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true