aboutsummaryrefslogtreecommitdiff
path: root/python/git-fame
diff options
context:
space:
mode:
Diffstat (limited to 'python/git-fame')
-rw-r--r--python/git-fame/git-fame.SlackBuild22
-rw-r--r--python/git-fame/git-fame.info8
2 files changed, 19 insertions, 11 deletions
diff --git a/python/git-fame/git-fame.SlackBuild b/python/git-fame/git-fame.SlackBuild
index fd4685bdd6..b6f00cb99e 100644
--- a/python/git-fame/git-fame.SlackBuild
+++ b/python/git-fame/git-fame.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for git-fame
# Copyright 2017-2021 Andrew Clemons, Wellington New Zealand
-# Copyright 2022-2023 Andrew Clemons, Tokyo Japan
+# Copyright 2022-2025 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,9 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=git-fame
-VERSION=${VERSION:-2.0.1}
-BUILD=${BUILD:-2}
+SRCNAM=${SRCNAM:-$(printf '%s\n' "$PRGNAM" | tr '-' '_')}
+VERSION=${VERSION:-2.1.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -57,6 +58,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -67,9 +71,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -77,7 +81,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/git-fame/git-fame.info b/python/git-fame/git-fame.info
index fc1dfdb759..f7a8a4de5b 100644
--- a/python/git-fame/git-fame.info
+++ b/python/git-fame/git-fame.info
@@ -1,10 +1,10 @@
PRGNAM="git-fame"
-VERSION="2.0.1"
+VERSION="2.1.0"
HOMEPAGE="https://pypi.python.org/pypi/git-fame"
-DOWNLOAD="https://files.pythonhosted.org/packages/7a/f2/fd903eafd3bf5d5dff0d5885a9fd9f25d3779968897e61d406c57ed0aaf9/git-fame-2.0.1.tar.gz"
-MD5SUM="b8b0be30c8b6bdcf5f9d23d61f03d676"
+DOWNLOAD="https://files.pythonhosted.org/packages/0c/86/e13c918e62315db39d69b653728e03faf8bfa37be880d0ef114322b480c6/git_fame-2.1.0.tar.gz"
+MD5SUM="295c5a8fbb2f86c9369eca78dd5a5a44"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-argopt python3-docopt tqdm python3-tabulate"
+REQUIRES="python-argopt python3-docopt tqdm python3-tabulate python3-wheel"
MAINTAINER="Andrew Clemons"
EMAIL="andrew.clemons@gmail.com"