aboutsummaryrefslogtreecommitdiff
path: root/python/cppy/cppy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/cppy/cppy.SlackBuild')
-rw-r--r--python/cppy/cppy.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/python/cppy/cppy.SlackBuild b/python/cppy/cppy.SlackBuild
index 60dd98223d034..bc15f9148a3e1 100644
--- a/python/cppy/cppy.SlackBuild
+++ b/python/cppy/cppy.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for cppy
# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cppy
-VERSION=${VERSION:-1.2.0}
+VERSION=${VERSION:-1.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,6 +64,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+export PYTHONPATH=/opt/python3.9/site-packages/
+
python3 setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \