aboutsummaryrefslogtreecommitdiff
path: root/python/cppy/cppy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/cppy/cppy.SlackBuild')
-rw-r--r--python/cppy/cppy.SlackBuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/python/cppy/cppy.SlackBuild b/python/cppy/cppy.SlackBuild
index db7be8704a..4af009093d 100644
--- a/python/cppy/cppy.SlackBuild
+++ b/python/cppy/cppy.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for cppy
# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
-# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
+# Copyright 2023-2025 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cppy
-VERSION=${VERSION:-1.2.1}
+VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -69,7 +69,15 @@ find -L . \
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages/
-python3 setup.py install --root $PKG
+# Hide `pip check` warning about incorrect setuptools version since the correct
+# version resides in /opt
+sed -i 's|>=61.2||' pyproject.toml
+
+# Get rid of scary "Package would be ignored" warning from newer setuptools
+sed -i 's|\[tool\.setuptools\]|&\ninclude-package-data = false|' pyproject.toml
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true