aboutsummaryrefslogtreecommitdiff
path: root/python/click/click.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/click/click.SlackBuild')
-rw-r--r--python/click/click.SlackBuild26
1 files changed, 5 insertions, 21 deletions
diff --git a/python/click/click.SlackBuild b/python/click/click.SlackBuild
index b72b7dc76b..67ec3ab5bf 100644
--- a/python/click/click.SlackBuild
+++ b/python/click/click.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for click
-# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2025 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -29,7 +29,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=click
-VERSION=${VERSION:-8.1.7}
+VERSION=${VERSION:-8.1.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -51,23 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -83,13 +66,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m flit_core.wheel
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst LICENSE.rst README.rst docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE.txt README.md docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install