aboutsummaryrefslogtreecommitdiff
path: root/python/buildbot/buildbot.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/buildbot/buildbot.SlackBuild')
-rw-r--r--python/buildbot/buildbot.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/python/buildbot/buildbot.SlackBuild b/python/buildbot/buildbot.SlackBuild
index 24d472eda4..29463996d4 100644
--- a/python/buildbot/buildbot.SlackBuild
+++ b/python/buildbot/buildbot.SlackBuild
@@ -28,8 +28,8 @@ PRGNAM=buildbot
SRCNAM=${PRGNAM#python-*}
# "pkg" stays first
PACKAGES="pkg www console_view grid_view waterfall_view wsgi_dashboards"
-VERSION=${VERSION:-3.11.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.2.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -89,13 +89,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
pushd $SRCNAM-$VERSION
python3 setup.py install --root=$PKG
popd
# Packages needs the buildbot-pkg package to be available
# Using the one from the installation (first one to be built)
OLD_PYTHONPATH=$PYTHONPATH
-export PYTHONPATH=$(find $PKG -type d -name site-packages)
+export PYTHONPATH="$PYTHONPATH:$(find $PKG -type d -name site-packages)"
for pkg in $PACKAGES; do
pushd ${SRCNAM}_${pkg}-${VERSION}
python3 setup.py install --root=$PKG