aboutsummaryrefslogtreecommitdiff
path: root/python/buildbot-badges
diff options
context:
space:
mode:
Diffstat (limited to 'python/buildbot-badges')
-rw-r--r--python/buildbot-badges/buildbot-badges.SlackBuild5
-rw-r--r--python/buildbot-badges/buildbot-badges.info6
2 files changed, 7 insertions, 4 deletions
diff --git a/python/buildbot-badges/buildbot-badges.SlackBuild b/python/buildbot-badges/buildbot-badges.SlackBuild
index fae6875f02..64b1047c39 100644
--- a/python/buildbot-badges/buildbot-badges.SlackBuild
+++ b/python/buildbot-badges/buildbot-badges.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=buildbot-badges
SRCNAM=${PRGNAM//-/_}
-VERSION=${VERSION:-3.11.3}
+VERSION=${VERSION:-4.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -84,6 +84,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
cd $SRCNAM-$VERSION
python3 setup.py install --root=$PKG
diff --git a/python/buildbot-badges/buildbot-badges.info b/python/buildbot-badges/buildbot-badges.info
index 5f53123ceb..cae68bcfbc 100644
--- a/python/buildbot-badges/buildbot-badges.info
+++ b/python/buildbot-badges/buildbot-badges.info
@@ -1,8 +1,8 @@
PRGNAM="buildbot-badges"
-VERSION="3.11.3"
+VERSION="4.2.1"
HOMEPAGE="https://buildbot.net/"
-DOWNLOAD="https://pypi.python.org/packages/source/b/buildbot_badges/buildbot_badges-3.11.3.tar.gz"
-MD5SUM="6d72c6d9def98bb31e544a2f265106d7"
+DOWNLOAD="https://pypi.python.org/packages/source/b/buildbot_badges/buildbot_badges-4.2.1.tar.gz"
+MD5SUM="94e486b0bd6cc9e2516cf69bfc456cdf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="buildbot python3-klein CairoSVG"