aboutsummaryrefslogtreecommitdiff
path: root/network/gnome-bluetooth
diff options
context:
space:
mode:
Diffstat (limited to 'network/gnome-bluetooth')
-rw-r--r--network/gnome-bluetooth/gnome-bluetooth.SlackBuild6
-rw-r--r--network/gnome-bluetooth/patches/01-meson.patch17
2 files changed, 22 insertions, 1 deletions
diff --git a/network/gnome-bluetooth/gnome-bluetooth.SlackBuild b/network/gnome-bluetooth/gnome-bluetooth.SlackBuild
index cab85243ada29..d381647dab680 100644
--- a/network/gnome-bluetooth/gnome-bluetooth.SlackBuild
+++ b/network/gnome-bluetooth/gnome-bluetooth.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gnome-bluetooth
VERSION=${VERSION:-3.34.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,6 +77,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Special thanks to Bob Funk, who kindly pointed this problem out and
+# provided a link to the patch fixing it.
+cat $CWD/patches/01-meson.patch | patch -p1 || exit
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
diff --git a/network/gnome-bluetooth/patches/01-meson.patch b/network/gnome-bluetooth/patches/01-meson.patch
new file mode 100644
index 0000000000000..79c0a08725da5
--- /dev/null
+++ b/network/gnome-bluetooth/patches/01-meson.patch
@@ -0,0 +1,17 @@
+# 08/02/2023: Allow newer versions of meson to build this package.
+# Special thanks to Bob Funk who kindly pointed this out.
+# Original patch url: https://gitlab.gnome.org/GNOME/gnome-bluetooth/-/commit/755fd758f866d3a3f7ca482942beee749f13a91e.patch
+
+diff --git a/sendto/meson.build b/sendto/meson.build
+index 24a4e394..3e233a03 100644
+--- a/sendto/meson.build
++++ b/sendto/meson.build
+@@ -22,7 +22,6 @@ desktop_in = configure_file(
+ )
+
+ i18n.merge_file (
+- desktop,
+ type: 'desktop',
+ input: desktop_in,
+ output: desktop,
+--