aboutsummaryrefslogtreecommitdiff
path: root/network/3proxy/3proxy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/3proxy/3proxy.SlackBuild')
-rw-r--r--network/3proxy/3proxy.SlackBuild25
1 files changed, 9 insertions, 16 deletions
diff --git a/network/3proxy/3proxy.SlackBuild b/network/3proxy/3proxy.SlackBuild
index 7f30c3add6fb..668da176f5f0 100644
--- a/network/3proxy/3proxy.SlackBuild
+++ b/network/3proxy/3proxy.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for 3proxy
# Copyright 2008, 2009 Ilya INSTE Ponetayev, <inste@mail.ru>
+# Copyright 2018 wigums pioneer22675@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +24,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=3proxy
-VERSION=${VERSION:-0.6.1}
+VERSION=${VERSION:-0.8.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
@@ -56,9 +57,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
-rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tgz
-cd $PRGNAM-$VERSION
+cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -66,11 +66,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/patches/Makefile.Linux.patch
-patch -p1 < $CWD/patches/fix_etcdir.patch
-patch -p1 < $CWD/patches/add3proxyuser.sh.patch
-patch -p1 < $CWD/patches/fixup_manpages.patch
-
make -f Makefile.Linux \
EXTRA_CFLAGS="$SLKCFLAGS" \
prefix=/usr \
@@ -98,22 +93,20 @@ mkdir -p $PKG/etc/rc.d
cat $CWD/rc.3proxy > $PKG/etc/rc.d/rc.3proxy.new
chmod 0755 $PKG/etc/rc.d/rc.3proxy.new
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a Changelog authors copying Readme news doc cfg contrib scripts \
+cp -a authors copying Readme doc cfg scripts \
$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
-find $PKG/usr/doc/$PRGNAM-$VERSION/contrib/ -type d -exec chmod 755 {} \;
-find $PKG/usr/doc/$PRGNAM-$VERSION/contrib/ -type f -exec chmod 644 {} \;
-
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}