aboutsummaryrefslogtreecommitdiff
path: root/multimedia/sickchill/sickchill.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/sickchill/sickchill.SlackBuild')
-rw-r--r--multimedia/sickchill/sickchill.SlackBuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/multimedia/sickchill/sickchill.SlackBuild b/multimedia/sickchill/sickchill.SlackBuild
index 19464ff0f0b2..66998c5490d3 100644
--- a/multimedia/sickchill/sickchill.SlackBuild
+++ b/multimedia/sickchill/sickchill.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sickchill
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sickchill
-VERSION=${VERSION:-2023.6.27}
+VERSION=${VERSION:-2024.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,6 +83,18 @@ find -L . \
# Revert changes that require SQLAlchmey > 2.0 until SBo catches up
patch -p1 < $CWD/use-older-SQLAlchemy.patch
+sed -i 's|>=2.0.0,<3.0.0|<2.0.0|' pyproject.toml
+
+# Correct python module names and remove version requirements
+sed -i 's|kodipydent-alt.*|kodipydent = "\*"|' pyproject.toml
+sed -i 's|new-rtorrent-python.*|rtorrent-python = "\*"|' pyproject.toml
+sed -i 's|python-twitter.*|twitter = "\*"|' pyproject.toml
+
+# Remove ipaddress module requirement as it's been included in python since 3.3
+sed -i '/ipaddress.*/d' pyproject.toml
+
+# Remove win-inet-pton requirement as it is for Windows
+sed -i '/win-inet-pton.*/d' pyproject.toml
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl