aboutsummaryrefslogtreecommitdiff
path: root/libraries/msgpack-c-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/msgpack-c-cpp')
-rw-r--r--libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild13
-rw-r--r--libraries/msgpack-c-cpp/msgpack-c-cpp.info6
2 files changed, 10 insertions, 9 deletions
diff --git a/libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild b/libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild
index e26f4c46e8..e1fd523cb5 100644
--- a/libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild
+++ b/libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild
@@ -2,7 +2,7 @@
# SlackBuild script for msgpack-c-cpp
-# Copyright 2024 Giancarlo Dessi, Cagliari, IT
+# Copyright 2024-2025 Giancarlo Dessi, Cagliari, IT
# Copyright 2021 Ruben Schuller <sb@rbn.im>
# Copyright 2014-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
@@ -31,10 +31,11 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=msgpack-c-cpp
-VERSION=${VERSION:-6.1.1}
+VERSION=${VERSION:-7.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+SRCNAM=msgpack-cxx
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -84,9 +85,9 @@ fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -94,7 +95,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-sed -i ./CMakeLists.txt -e "s/VERSION 3.1 FATAL_ERROR/VERSION 3.5 FATAL_ERROR/g"
+sed -i ./CMakeLists.txt -e "s/CMAKE_MINIMUM_REQUIRED (VERSION 3.5)/CMAKE_MINIMUM_REQUIRED (VERSION 3.10)/g"
mkdir -p build
cd build
diff --git a/libraries/msgpack-c-cpp/msgpack-c-cpp.info b/libraries/msgpack-c-cpp/msgpack-c-cpp.info
index aed8f36148..0e25eba2b4 100644
--- a/libraries/msgpack-c-cpp/msgpack-c-cpp.info
+++ b/libraries/msgpack-c-cpp/msgpack-c-cpp.info
@@ -1,8 +1,8 @@
PRGNAM="msgpack-c-cpp"
-VERSION="6.1.1"
+VERSION="7.0.0"
HOMEPAGE="https://github.com/msgpack/msgpack-c"
-DOWNLOAD="https://github.com/msgpack/msgpack-c/archive/cpp-6.1.1/msgpack-c-cpp-6.1.1.tar.gz"
-MD5SUM="a0398798d8b9733bd5cd87a6d2f0b05f"
+DOWNLOAD="https://github.com/msgpack/msgpack-c/releases/download/cpp-7.0.0/msgpack-cxx-7.0.0.tar.gz"
+MD5SUM="4f634a36531fb2ba5b92038c42483871"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""