aboutsummaryrefslogtreecommitdiff
path: root/libraries/libportal/libportal.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libportal/libportal.SlackBuild')
-rw-r--r--libraries/libportal/libportal.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/libraries/libportal/libportal.SlackBuild b/libraries/libportal/libportal.SlackBuild
index 0310533eb3..311f981efa 100644
--- a/libraries/libportal/libportal.SlackBuild
+++ b/libraries/libportal/libportal.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for libportal
-# Copyright 2020-2023 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2020-2025 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libportal
-VERSION=${VERSION:-0.6}
+VERSION=${VERSION:-0.8.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -83,8 +80,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/0.6-backports.patch
-sed -i "s|get_option('datadir') / 'doc'|get_option('prefix') / 'doc'|" doc/meson.build
+sed -i "s|get_option('datadir') / 'doc'|get_option('prefix') / 'doc'|" doc/meson.build || exit 1
+export PATH=/usr/lib$LIBDIRSUFFIX/qt6/libexec:$PATH
mkdir build
cd build