aboutsummaryrefslogtreecommitdiff
path: root/games/SpaceZero/SpaceZero.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/SpaceZero/SpaceZero.SlackBuild')
-rw-r--r--games/SpaceZero/SpaceZero.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/SpaceZero/SpaceZero.SlackBuild b/games/SpaceZero/SpaceZero.SlackBuild
index 911f5e7ad6a8..9b1f34a8d206 100644
--- a/games/SpaceZero/SpaceZero.SlackBuild
+++ b/games/SpaceZero/SpaceZero.SlackBuild
@@ -22,6 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220222 bkw: Modified by SlackBuilds.org: fix build on 15.0.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=SpaceZero
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,12 +75,15 @@ cd $SRCNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
patch -p1 < $CWD/Makefile.patch
+# 20220222 bkw: SLKCFLAGS weren't even being used.
+sed -i "s,-O3,$SLKCFLAGS -fcommon," Makefile
+
make
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \