aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--libraries/nDPI/nDPI.SlackBuild15
-rw-r--r--libraries/nDPI/nDPI.info6
2 files changed, 7 insertions, 14 deletions
diff --git a/libraries/nDPI/nDPI.SlackBuild b/libraries/nDPI/nDPI.SlackBuild
index a8068d374ed9..bb5958dbbe86 100644
--- a/libraries/nDPI/nDPI.SlackBuild
+++ b/libraries/nDPI/nDPI.SlackBuild
@@ -23,7 +23,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=nDPI
-VERSION=${VERSION:-4.6}
+VERSION=${VERSION:-4.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -72,9 +72,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} +
sed -i 's|$(PREFIX)$(libdir)|$(libdir)|g' src/lib/Makefile.in
@@ -100,13 +100,9 @@ make
make install-strip DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-rm $PKG/usr/lib64/libndpi.a
-
-#find $PKG/usr/man -type f -exec gzip -9 {} \;
-#for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+rm $PKG/usr/lib${LIBDIRSUFFIX}/libndpi.a
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
cp -ar \
doc \
CHANGELOG.md \
@@ -115,9 +111,6 @@ cp -ar \
COPYING \
wireshark \
$PKG/usr/doc/$PRGNAM-$VERSION
-
-
-
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/nDPI/nDPI.info b/libraries/nDPI/nDPI.info
index 469fb06f36e7..fe17d2063ade 100644
--- a/libraries/nDPI/nDPI.info
+++ b/libraries/nDPI/nDPI.info
@@ -1,8 +1,8 @@
PRGNAM="nDPI"
-VERSION="4.6"
+VERSION="4.8"
HOMEPAGE="https://github.com/ntop/nDPI"
-DOWNLOAD="https://github.com/ntop/nDPI/archive/4.6/nDPI-4.6.tar.gz"
-MD5SUM="1803f5f3999e1dc3a2454d437b11e9ba"
+DOWNLOAD="https://github.com/ntop/nDPI/archive/4.8/nDPI-4.8.tar.gz"
+MD5SUM="41a5437fa7d274f59f852b17b776558f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libmaxminddb"