aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--network/bpfmon/README6
-rw-r--r--network/bpfmon/bpfmon.SlackBuild99
-rw-r--r--network/bpfmon/bpfmon.info10
-rw-r--r--network/bpfmon/makefile.patch28
-rw-r--r--network/bpfmon/slack-desc19
5 files changed, 162 insertions, 0 deletions
diff --git a/network/bpfmon/README b/network/bpfmon/README
new file mode 100644
index 000000000000..578ffa5b3476
--- /dev/null
+++ b/network/bpfmon/README
@@ -0,0 +1,6 @@
+BPF based visual packet rate monitor.
+While tcpdump shows what packets are going through the network,
+bpfmon will show how much in terms of bytes per second and packets
+per second in a nice pseudo-graphical terminal interface.
+bpfmon also supports monitoring an iptables rule that is selected
+by command line option or selected from a menu.
diff --git a/network/bpfmon/bpfmon.SlackBuild b/network/bpfmon/bpfmon.SlackBuild
new file mode 100644
index 000000000000..b2c5c7b26d00
--- /dev/null
+++ b/network/bpfmon/bpfmon.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/bash
+
+# Slackware build script for bpfmon
+
+# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=bpfmon
+VERSION=${VERSION:-2.50}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/makefile.patch
+sed -i "s|share/man|man|" Makefile
+
+CFLAGS="$SLKCFLAGS" \
+make install DESTDIR=$PKG PREFIX=/usr
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/bpfmon/bpfmon.info b/network/bpfmon/bpfmon.info
new file mode 100644
index 000000000000..cb4e56c3edd9
--- /dev/null
+++ b/network/bpfmon/bpfmon.info
@@ -0,0 +1,10 @@
+PRGNAM="bpfmon"
+VERSION="2.50"
+HOMEPAGE="https://github.com/bbonev/bpfmon"
+DOWNLOAD="https://github.com/bbonev/bpfmon/releases/download/v2.50/bpfmon-2.50.tar.xz"
+MD5SUM="c492f5d5949aaa55346eb5cd49a1d637"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="yascreen"
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/network/bpfmon/makefile.patch b/network/bpfmon/makefile.patch
new file mode 100644
index 000000000000..431c58a85aa6
--- /dev/null
+++ b/network/bpfmon/makefile.patch
@@ -0,0 +1,28 @@
+From 8d2d7d8b9d5f5d5ec3ed8241ff93654f1ebb8973 Mon Sep 17 00:00:00 2001
+From: Boian Bonev <bbonev@ipacct.com>
+Date: Tue, 28 Sep 2021 03:26:08 +0300
+Subject: [PATCH] better install target
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+- remove -T from install for busybox compat (Milan P. Stanić <mps@arvanta.net>)
+- also install the man page
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 54d6cbb..a629710 100644
+--- a/Makefile
++++ b/Makefile
+@@ -81,7 +81,8 @@ clean:
+ rm -f bpfmon bpfmon.o psort psort.o
+
+ install: bpfmon
+- $(INSTALL) -TD -m 0755 $< $(DESTDIR)$(PREFIX)/sbin/$<
++ $(INSTALL) -D -m 0755 $< $(DESTDIR)$(PREFIX)/sbin/$<
++ $(INSTALL) -D -m 0644 bpfmon.8 $(DESTDIR)$(PREFIX)/share/man/man8/bpfmon.8
+ $(STRIP) $(DESTDIR)$(PREFIX)/sbin/$<
+
+ mkotar:
diff --git a/network/bpfmon/slack-desc b/network/bpfmon/slack-desc
new file mode 100644
index 000000000000..579a413f5220
--- /dev/null
+++ b/network/bpfmon/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bpfmon: bpfmon (network packet monitor)
+bpfmon:
+bpfmon: BPF based visual packet rate monitor.
+bpfmon: While tcpdump shows what packets are going through the network,
+bpfmon: bpfmon will show how much in terms of bytes per second and packets
+bpfmon: per second in a nice pseudo-graphical terminal interface.
+bpfmon: bpfmon also supports monitoring an iptables rule that is selected
+bpfmon: by command line option or selected from a menu.
+bpfmon:
+bpfmon: homepage: https://github.com/bbonev/bpfmon
+bpfmon: