aboutsummaryrefslogtreecommitdiff
path: root/thirdparty
diff options
context:
space:
mode:
authorChristoph Willing <chris.willing@linux.com>2022-01-27 18:35:29 +1000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-04 17:53:47 +0700
commit87b6cec3fd7ee36da7627d9c152a8259c4e96caa (patch)
tree595b4b22f387973d843c432273d459c08a9fe11c /thirdparty
parent6e04008caa298a7e6eea75fbda73d07e01f79a78 (diff)
downloadslackbuilds-87b6cec3fd7ee36da7627d9c152a8259c4e96caa.tar.xz
thirdparty/paho-mqtt: Added
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'thirdparty')
-rw-r--r--thirdparty/paho-mqtt/README10
-rw-r--r--thirdparty/paho-mqtt/paho-mqtt.SlackBuild91
-rw-r--r--thirdparty/paho-mqtt/paho-mqtt.info10
-rw-r--r--thirdparty/paho-mqtt/slack-desc20
4 files changed, 131 insertions, 0 deletions
diff --git a/thirdparty/paho-mqtt/README b/thirdparty/paho-mqtt/README
new file mode 100644
index 000000000000..b328c8bd8f24
--- /dev/null
+++ b/thirdparty/paho-mqtt/README
@@ -0,0 +1,10 @@
+This document describes the source code for the Eclipse Paho MQTT Python client library, which implements versions 5.0, 3.1.1, and 3.1 of the MQTT protocol.
+
+This code provides a client class which enable applications to connect to an MQTT broker to publish messages, and to subscribe to topics and receive published messages. It also provides some helper functions to make publishing one off messages to an MQTT server very straightforward.
+
+It supports Python 2.7.9+ or 3.6+.
+
+The MQTT protocol is a machine-to-machine (M2M)/"Internet of Things" connectivity protocol. Designed as an extremely lightweight publish/subscribe messaging transport, it is useful for connections with remote locations where a small code footprint is required and/or network bandwidth is at a premium.
+
+Paho is an Eclipse Foundation project.
+
diff --git a/thirdparty/paho-mqtt/paho-mqtt.SlackBuild b/thirdparty/paho-mqtt/paho-mqtt.SlackBuild
new file mode 100644
index 000000000000..1d0e228f448e
--- /dev/null
+++ b/thirdparty/paho-mqtt/paho-mqtt.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for paho-mqtt
+
+# Copyright 2022 Christoph Willing Brisbane, Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=paho-mqtt
+SRCNAM=paho.mqtt.python
+VERSION=${VERSION:-1.6.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE.* README.* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/thirdparty/paho-mqtt/paho-mqtt.info b/thirdparty/paho-mqtt/paho-mqtt.info
new file mode 100644
index 000000000000..8ad110b4a806
--- /dev/null
+++ b/thirdparty/paho-mqtt/paho-mqtt.info
@@ -0,0 +1,10 @@
+PRGNAM="paho"
+VERSION="1.6.1"
+HOMEPAGE="http://eclipse.org/paho"
+DOWNLOAD="https://github.com/eclipse/paho.mqtt.python/archive/refs/tags/v1.6.1/paho.mqtt.python-1.6.1.tar.gz"
+MD5SUM="00c3381d7deacc7ac8b220f3b9d689c6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Christoph Willing"
+EMAIL="chris.willing@linux.com"
diff --git a/thirdparty/paho-mqtt/slack-desc b/thirdparty/paho-mqtt/slack-desc
new file mode 100644
index 000000000000..89ad040d88de
--- /dev/null
+++ b/thirdparty/paho-mqtt/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+paho-mqtt: paho-mqtt (MQTT Python client library)
+paho-mqtt:
+paho-mqtt: This code provides a client class which enable applications to connect
+paho-mqtt: to an MQTT broker to publish messages, and to subscribe to topics and
+paho-mqtt: receive published messages. It supports Python 2.7.9+ or 3.6+.
+paho-mqtt:
+paho-mqtt: Paho is an Eclipse Foundation project.
+paho-mqtt:
+paho-mqtt:
+paho-mqtt:
+paho-mqtt:
+