aboutsummaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-04-23 12:34:58 +0700
committerRobby Workman <rworkman@slackbuilds.org>2021-04-23 01:11:25 -0500
commitcd18c0721da707654ccc45da8a7d4d9ef22a7b47 (patch)
tree0a12c5813fba94d4ef709bb19e521aae46b0a954 /system
parent577b1a1941671b9e8fc1efc3ec00d938ff10e753 (diff)
downloadslackbuilds-cd18c0721da707654ccc45da8a7d4d9ef22a7b47.tar.xz
system/sqlite2: Removed.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/sqlite2/Makefile.patch21
-rw-r--r--system/sqlite2/README7
-rw-r--r--system/sqlite2/slack-desc19
-rw-r--r--system/sqlite2/sqlite2.SlackBuild118
-rw-r--r--system/sqlite2/sqlite2.info12
5 files changed, 0 insertions, 177 deletions
diff --git a/system/sqlite2/Makefile.patch b/system/sqlite2/Makefile.patch
deleted file mode 100644
index f80d057feb71..000000000000
--- a/system/sqlite2/Makefile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.in.orig 2014-08-10 08:46:19.947934827 +0700
-+++ Makefile.in 2014-08-10 08:46:38.961957767 +0700
-@@ -465,14 +465,14 @@
- mv $(DOC) doc
-
- install: sqlite libsqlite.la sqlite.h
-- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib
-- $(LTINSTALL) libsqlite.la $(DESTDIR)$(exec_prefix)/lib
-+ $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib64
-+ $(LTINSTALL) libsqlite.la $(DESTDIR)$(exec_prefix)/lib64
- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/bin
- $(LTINSTALL) sqlite $(DESTDIR)$(exec_prefix)/bin
- $(INSTALL) -d $(DESTDIR)$(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(DESTDIR)$(prefix)/include
-- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
-- $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
-+ $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib64/pkgconfig;
-+ $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)$(exec_prefix)/lib64/pkgconfig;
-
- clean:
- rm -f *.lo *.la *.o sqlite@TARGET_EXEEXT@ libsqlite.la sqlite.h opcodes.*
diff --git a/system/sqlite2/README b/system/sqlite2/README
deleted file mode 100644
index 4cd7724fa57f..000000000000
--- a/system/sqlite2/README
+++ /dev/null
@@ -1,7 +0,0 @@
-SQLite is a small C library that implements a self-contained, embeddable,
-zero-configuration SQL database engine. The distribution contains a
-standalone command-line database access program as well.
-
-This is a legacy build that is no longer maintained or supported by the
-upstream developers at sqlite.org. This sqlite2 package can be installed
-in parallel with the sqlite (version 3) package included in Slackware.
diff --git a/system/sqlite2/slack-desc b/system/sqlite2/slack-desc
deleted file mode 100644
index 1e003807692a..000000000000
--- a/system/sqlite2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-sqlite2: sqlite2 (simple, self contained database engine)
-sqlite2:
-sqlite2: SQLite is a small C library that implements a self-contained,
-sqlite2: embeddable, zero-configuration SQL database engine. The distribution
-sqlite2: contains a standalone command-line database access program as well.
-sqlite2:
-sqlite2: SQLite version 2 is installable in parallel with SQLite version 3,
-sqlite2: which is included in Slackware.
-sqlite2:
-sqlite2: Homepage: http://www.sqlite.org/
-sqlite2:
diff --git a/system/sqlite2/sqlite2.SlackBuild b/system/sqlite2/sqlite2.SlackBuild
deleted file mode 100644
index 66ffb2774e72..000000000000
--- a/system/sqlite2/sqlite2.SlackBuild
+++ /dev/null
@@ -1,118 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for sqlite2
-# As sqlite version 2 is no longer maintained in favour of version 3,
-# we'll grab the source and security patches from the Debian project.
-# File names in v.2 and v.3 do not overlap, so both packages can safely coexist
-
-# Written by V'yacheslav Stetskevych
-# Now maintained by Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=sqlite2
-VERSION=${VERSION:-2.8.17_7}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=sqlite
-SRCVERSION=$(printf "$VERSION" | cut -d _ -f 1)
-PATCHLEVEL=$(printf "$VERSION" | cut -d _ -f 2)
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$SRCVERSION
-tar xvf $CWD/${SRCNAM}_${SRCVERSION}.orig.tar.gz
-cd $SRCNAM-$SRCVERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Apply the debian patchset, which creates the "debian" directory
-zcat $CWD/${SRCNAM}_$SRCVERSION-$PATCHLEVEL.diff.gz | patch -p1
-# Apply individual debian patches
-cat debian/patches/* | patch -p1
-
-if [ "$ARCH" = "x86_64" ]; then
- patch -p0 < $CWD/Makefile.patch
-fi
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-static \
- --enable-utf8 \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Install the manpage
-mkdir -p $PKG/usr/man/man1
-gzip -9 < sqlite.1 > $PKG/usr/man/man1/sqlite.1.gz
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/sqlite2/sqlite2.info b/system/sqlite2/sqlite2.info
deleted file mode 100644
index aaa7b6674fa7..000000000000
--- a/system/sqlite2/sqlite2.info
+++ /dev/null
@@ -1,12 +0,0 @@
-PRGNAM="sqlite2"
-VERSION="2.8.17_7"
-HOMEPAGE="http://www.sqlite.org"
-DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/s/sqlite/sqlite_2.8.17.orig.tar.gz \
- http://archive.debian.org/debian/pool/main/s/sqlite/sqlite_2.8.17-7.diff.gz"
-MD5SUM="04f15ed552134b06528b3628be7d7315 \
- 9d926474caaed0d12f2fb418bdcf1ccf"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Willy Sudiarto Raharjo"
-EMAIL="willysr@slackbuilds.org"