aboutsummaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorAndrew Clemons <andrew.clemons@gmail.com>2022-02-18 20:28:58 +1300
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-19 12:10:41 +0700
commitbd82fe76b19b86230309b8655b0c3b708ba9a523 (patch)
tree887c4941d0b7b5495d515924f89502324c13b2b7 /system
parenteebebdd1679608ffd1bff4f3eb870940377914ea (diff)
downloadslackbuilds-bd82fe76b19b86230309b8655b0c3b708ba9a523.tar.xz
system/tilix: Removed (ftbfs, no maintainer).
Newer versions 1.9.x need dependencies which are currently not on SBo. Can be resubmitted with an update if this changes in future. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/tilix/README6
-rw-r--r--system/tilix/doinst.sh15
-rw-r--r--system/tilix/slack-desc19
-rw-r--r--system/tilix/tilix.SlackBuild107
-rw-r--r--system/tilix/tilix.info10
5 files changed, 0 insertions, 157 deletions
diff --git a/system/tilix/README b/system/tilix/README
deleted file mode 100644
index 3a18a5c16533..000000000000
--- a/system/tilix/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Tilix is an advanced GTK3 tiling terminal emulator that follows the
-Gnome Human Interface Guidelines.
-It was formerly known as Terminix.
-
-To fix the configuration warning at startup enable
-'Run command as a login shell' in the Default profile.
diff --git a/system/tilix/doinst.sh b/system/tilix/doinst.sh
deleted file mode 100644
index 401d9877955b..000000000000
--- a/system/tilix/doinst.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
-if [ -e usr/share/glib-2.0/schemas ]; then
- if [ -x /usr/bin/glib-compile-schemas ]; then
- /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
- fi
-fi
diff --git a/system/tilix/slack-desc b/system/tilix/slack-desc
deleted file mode 100644
index 98ff51e4edd3..000000000000
--- a/system/tilix/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-tilix: tilix (Tiling terminal emulator)
-tilix:
-tilix: Tilix is an advanced GTK3 tiling terminal emulator that
-tilix: follows the Gnome Human Interface Guidelines.
-tilix:
-tilix:
-tilix:
-tilix:
-tilix:
-tilix:
-tilix:
diff --git a/system/tilix/tilix.SlackBuild b/system/tilix/tilix.SlackBuild
deleted file mode 100644
index 6f4f5e6d13d7..000000000000
--- a/system/tilix/tilix.SlackBuild
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for tilix
-
-# Copyright 2017-2018 Philip van der Hoeven, Almere, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=tilix
-VERSION=${VERSION:-1.8.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Remove suffixes from pkgconfig files
-sed -i 's/gtkd-3$DC_SUFFIX/gtkd-3/g' configure.ac
-sed -i 's/vted-3$DC_SUFFIX/vted-3/g' configure.ac
-
-./autogen.sh
-./configure --prefix=/usr
-make DC='dmd' DCFLAGS='-O -inline -release -version=StdLoggerDisableTrace'
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/share/man $PKG/usr/
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CREDITS.md LICENSE README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/tilix/tilix.info b/system/tilix/tilix.info
deleted file mode 100644
index df5b41e07d12..000000000000
--- a/system/tilix/tilix.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="tilix"
-VERSION="1.8.5"
-HOMEPAGE="https://gnunn1.github.io/tilix-web/"
-DOWNLOAD="UNSUPPORTED"
-MD5SUM=""
-DOWNLOAD_x86_64="https://github.com/gnunn1/tilix/archive/1.8.5/tilix-1.8.5.tar.gz"
-MD5SUM_x86_64="ff94fd12649f5502af20b6a5666a3bbf"
-REQUIRES="GtkD po4a"
-MAINTAINER="Philip van der Hoeven"
-EMAIL="philip@vd-hoeven.nl"