aboutsummaryrefslogtreecommitdiff
path: root/system/qemu
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2021-05-03 23:08:19 +0200
committerRobby Workman <rworkman@slackbuilds.org>2021-05-04 19:29:31 -0500
commit50b70d037b41846e3e50d40693b7890402b7f94e (patch)
tree7b6bc122384bc08a46b57298cf95e767e51dfc2b /system/qemu
parent9cea6526435a7a7c381e661abfefe1a69d26d20f (diff)
downloadslackbuilds-50b70d037b41846e3e50d40693b7890402b7f94e.tar.xz
system/qemu: Updated for version 6.0.0.
Added the optional dependency liburing Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/qemu')
-rw-r--r--system/qemu/README2
-rw-r--r--system/qemu/linker-no-pie.patch40
-rw-r--r--system/qemu/qemu.SlackBuild20
-rw-r--r--system/qemu/qemu.info6
4 files changed, 14 insertions, 54 deletions
diff --git a/system/qemu/README b/system/qemu/README
index a7d678fa8d33..593146af9ae3 100644
--- a/system/qemu/README
+++ b/system/qemu/README
@@ -39,7 +39,7 @@ your processor) prior to launching qemu-system-ARCH with kvm enabled.
For older/unmaintained qemu frontends, this build also creates a symlink
to qemu-system-ARCH at /usr/bin/qemu-kvm.
-libiscsi, libcacard, spice, usbredir, virglrenderer,
+libiscsi, libcacard, liburing, spice, usbredir, virglrenderer,
device-tree-compiler, libnfs, snappy, glusterfs and vde2 are optional
dependencies.
diff --git a/system/qemu/linker-no-pie.patch b/system/qemu/linker-no-pie.patch
deleted file mode 100644
index 615d9a4ffa7b..000000000000
--- a/system/qemu/linker-no-pie.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/configure b/configure
-index 3f823ed163..61c17c2dde 100755
---- a/configure
-+++ b/configure
-@@ -2133,7 +2133,6 @@ EOF
- # Check we support --no-pie first; we will need this for building ROMs.
- if compile_prog "-Werror -fno-pie" "-no-pie"; then
- CFLAGS_NOPIE="-fno-pie"
-- LDFLAGS_NOPIE="-no-pie"
- fi
-
- if test "$static" = "yes"; then
-@@ -2149,7 +2148,6 @@ if test "$static" = "yes"; then
- fi
- elif test "$pie" = "no"; then
- CONFIGURE_CFLAGS="$CFLAGS_NOPIE $CONFIGURE_CFLAGS"
-- CONFIGURE_LDFLAGS="$LDFLAGS_NOPIE $CONFIGURE_LDFLAGS"
- elif compile_prog "-Werror -fPIE -DPIE" "-pie"; then
- CONFIGURE_CFLAGS="-fPIE -DPIE $CONFIGURE_CFLAGS"
- CONFIGURE_LDFLAGS="-pie $CONFIGURE_LDFLAGS"
-@@ -6768,7 +6766,6 @@ echo "QEMU_CXXFLAGS=$QEMU_CXXFLAGS" >> $config_host_mak
- echo "GLIB_CFLAGS=$glib_cflags" >> $config_host_mak
- echo "GLIB_LIBS=$glib_libs" >> $config_host_mak
- echo "QEMU_LDFLAGS=$QEMU_LDFLAGS" >> $config_host_mak
--echo "LDFLAGS_NOPIE=$LDFLAGS_NOPIE" >> $config_host_mak
- echo "LD_I386_EMULATION=$ld_i386_emulation" >> $config_host_mak
- echo "EXESUF=$EXESUF" >> $config_host_mak
- echo "HOST_DSOSUF=$HOST_DSOSUF" >> $config_host_mak
-diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
-index 084fc10f05..30771f8d17 100644
---- a/pc-bios/optionrom/Makefile
-+++ b/pc-bios/optionrom/Makefile
-@@ -41,7 +41,6 @@ override CFLAGS += $(call cc-option, $(Wa)-32)
-
- LD_I386_EMULATION ?= elf_i386
- override LDFLAGS = -m $(LD_I386_EMULATION) -T $(SRC_DIR)/flat.lds
--override LDFLAGS += $(LDFLAGS_NOPIE)
-
- all: multiboot.bin linuxboot.bin linuxboot_dma.bin kvmvapic.bin pvh.bin
-
diff --git a/system/qemu/qemu.SlackBuild b/system/qemu/qemu.SlackBuild
index e2e1bae37f00..895748fb012e 100644
--- a/system/qemu/qemu.SlackBuild
+++ b/system/qemu/qemu.SlackBuild
@@ -59,7 +59,8 @@
# 6.2 16-Nov-2020 version update, 14.2 final release.
PRGNAM=qemu
-VERSION=${VERSION:-5.2.0}
+VERSION=${VERSION:-6.0.0}
+SRCVER=$(echo $VERSION | tr _ - )
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -102,14 +103,17 @@ fi
# Needed to build man pages if built after plain "su"
export PATH=$PATH:/usr/share/texmf/bin
+# Autodetect liburing support
+uring="dis" ; if pkg-config --exists liburing ; then uring="en" ; fi
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.xz
+cd $PRGNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -135,11 +139,6 @@ else
with_vnc="--disable-vnc"
fi
-# temp fix until upstream catches up.
-# ld: Error: unable to disambiguate: -no-pie (did you mean --no-pie ?)
-# https://lists.gnu.org/archive/html/qemu-devel/2020-12/msg03684.html
-patch -p1 < $CWD/linker-no-pie.patch
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -156,6 +155,7 @@ CXXFLAGS="$SLKCFLAGS" \
--enable-sdl \
--enable-jemalloc \
--enable-nettle \
+ --${uring}able-linux-io-uring \
--audio-drv-list=${AUDIODRIVERS} \
$with_vnc \
$targets
@@ -193,7 +193,7 @@ fi
# Add docs to the proper location
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING* CODING_STYLE.rst LICENSE MAINTAINERS README.rst docs/* \
+cp -a COPYING* LICENSE MAINTAINERS README.rst docs/* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/system/qemu/qemu.info b/system/qemu/qemu.info
index 6455e13c4c37..0f518ece9e25 100644
--- a/system/qemu/qemu.info
+++ b/system/qemu/qemu.info
@@ -1,8 +1,8 @@
PRGNAM="qemu"
-VERSION="5.2.0"
+VERSION="6.0.0"
HOMEPAGE="https://www.qemu.org"
-DOWNLOAD="https://download.qemu.org/qemu-5.2.0.tar.xz"
-MD5SUM="179f86928835da857c237b42f4b2df73"
+DOWNLOAD="https://download.qemu.org/qemu-6.0.0.tar.xz"
+MD5SUM="cce185dc0119546e395909e8a71a75bb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""