aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-15 23:13:48 +0700
committerRobby Workman <rworkman@slackbuilds.org>2021-04-21 19:56:21 -0500
commitfc30df75b3533e1a1a969382fc2ae91cc9871cad (patch)
tree566f5d82b6277f061680e0fd6485e3e2397cdb49 /python
parentf2c7b7443118508630429153046a2fc33ff27684 (diff)
downloadslackbuilds-fc30df75b3533e1a1a969382fc2ae91cc9871cad.tar.xz
python/pylirc: Removed (No maintainer).
Diffstat (limited to 'python')
-rw-r--r--python/pylirc/README2
-rw-r--r--python/pylirc/pylirc.SlackBuild66
-rw-r--r--python/pylirc/pylirc.info10
-rw-r--r--python/pylirc/slack-desc19
4 files changed, 0 insertions, 97 deletions
diff --git a/python/pylirc/README b/python/pylirc/README
deleted file mode 100644
index 464f05a68d8a..000000000000
--- a/python/pylirc/README
+++ /dev/null
@@ -1,2 +0,0 @@
-pyLirc is a module for Python that interacts with lirc to give Python
-programs the ability to receive commands from remote controls.
diff --git a/python/pylirc/pylirc.SlackBuild b/python/pylirc/pylirc.SlackBuild
deleted file mode 100644
index 6c3e1a6fc905..000000000000
--- a/python/pylirc/pylirc.SlackBuild
+++ /dev/null
@@ -1,66 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pylirc
-
-# Written by Pablo Santamaria (pablosantamaria@gmail.com)
-
-PRGNAM=pylirc
-VERSION=${VERSION:-0.0.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pylirc/pylirc.info b/python/pylirc/pylirc.info
deleted file mode 100644
index 8e414e422759..000000000000
--- a/python/pylirc/pylirc.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pylirc"
-VERSION="0.0.5"
-HOMEPAGE="http://pylirc.mccabe.nu/"
-DOWNLOAD="http://downloads.sourceforge.net/sourceforge/pylirc/pylirc-0.0.5.tar.gz"
-MD5SUM="4e3b6b50485610e273fededdb25b47ad"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="lirc"
-MAINTAINER="Pablo Santamaria"
-EMAIL="pablosantamaria@gmail.com"
diff --git a/python/pylirc/slack-desc b/python/pylirc/slack-desc
deleted file mode 100644
index 44cfbb0aa428..000000000000
--- a/python/pylirc/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pylirc: pylirc (Python lirc module)
-pylirc:
-pylirc: pyLirc is a module for Python that interacts with lirc to give Python
-pylirc: programs the ability to receive commands from remote controls.
-pylirc:
-pylirc:
-pylirc:
-pylirc:
-pylirc:
-pylirc:
-pylirc: