aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorVijay Marcel <vijaymarcel@gmail.com>2023-10-17 19:14:09 +0530
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-19 13:15:51 +0700
commitfb762169955003632b085907398aabc3db49256b (patch)
tree8056273c04bb01447db94d2b1016def10200bcbd /python
parent543b4e7cbc1ec86a70becef2fc1b885a2939f49a (diff)
downloadslackbuilds-fb762169955003632b085907398aabc3db49256b.tar.xz
python/python-fonttools: Removed (use python3-fonttools)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-fonttools/README12
-rw-r--r--python/python-fonttools/python-fonttools.SlackBuild107
-rw-r--r--python/python-fonttools/python-fonttools.info10
-rw-r--r--python/python-fonttools/slack-desc19
4 files changed, 0 insertions, 148 deletions
diff --git a/python/python-fonttools/README b/python/python-fonttools/README
deleted file mode 100644
index 54c96a23e4e3..000000000000
--- a/python/python-fonttools/README
+++ /dev/null
@@ -1,12 +0,0 @@
-python-fonttools - A library to manipulate font files from Python.
-
-Optional dependencies:
-
-lxml – faster backend for XML files reading/writing
-
-python3-matplotlib – for visualizing
-DesignSpaceDocument and resulting VariationModel
-
-python-reportlab – to drawing glyphs as PNG images
-
-python3-sympy – for symbolic font statistics analysis
diff --git a/python/python-fonttools/python-fonttools.SlackBuild b/python/python-fonttools/python-fonttools.SlackBuild
deleted file mode 100644
index 541dcfa76e1a..000000000000
--- a/python/python-fonttools/python-fonttools.SlackBuild
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-fonttools
-
-# Copyright 2017-2019,2022 Andrew Clemons, Wellington New Zealand
-# Copyright 2023 Vijay Marcel
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-fonttools
-SRCNAM=fonttools
-VERSION=${VERSION:-4.39.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2 -fPIC"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2 -fPIC"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-march=x86-64 -mtune=native -pipe -O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv -v $PKG/usr/share/man $PKG/usr
-rm -rvf $PKG/usr/share
-
-cd Doc
-make singlehtml
-make man
-mv -v $TMP/$SRCNAM-$VERSION/Doc/build/man/fonttools.1 $PKG/usr/man/man1/
-cd ..
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CONTRIBUTING.md LICENSE.external LICENSE README.rst CODE_OF_CONDUCT.md NEWS.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-fonttools/python-fonttools.info b/python/python-fonttools/python-fonttools.info
deleted file mode 100644
index 6fd5ed430e4a..000000000000
--- a/python/python-fonttools/python-fonttools.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-fonttools"
-VERSION="4.39.4"
-HOMEPAGE="https://github.com/fonttools/fonttools"
-DOWNLOAD="https://github.com/fonttools/fonttools/archive/4.39.4/fonttools-4.39.4.tar.gz"
-MD5SUM="fbdb8b744ba6826c4ebf5c0753232257"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-unicodedata2 Sphinx sphinx-rtd-theme munkres python3-scipy zopfli python3-fs python3-uharfbuzz freetype-py"
-MAINTAINER="Vijay Marcel"
-EMAIL="vijaymrcel@outlook.com"
diff --git a/python/python-fonttools/slack-desc b/python/python-fonttools/slack-desc
deleted file mode 100644
index 1972e8b860e2..000000000000
--- a/python/python-fonttools/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-fonttools: python-fonttools (A library to manipulate font files from Python.)
-python-fonttools:
-python-fonttools: fontTools is a library for manipulating fonts, written in Python. The
-python-fonttools: project includes the TTX tool, that can convert TrueType and
-python-fonttools: OpenType fonts to and from an XML text format, which is also called
-python-fonttools: TTX.
-python-fonttools:
-python-fonttools:
-python-fonttools:
-python-fonttools: https://github.com/fonttools/fonttools
-python-fonttools: