aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorTonus <tonus1@free.fr>2024-01-05 08:13:45 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-05 09:07:17 +0700
commitd69fac60858ba5df9c51cad29574e51d2d0fbbe1 (patch)
tree4f1fffcf11243eb571dcc86c545f297a097cdcea /python
parentf9247e4d97c7f878c9c82dc033f30913a6c2e813 (diff)
downloadslackbuilds-d69fac60858ba5df9c51cad29574e51d2d0fbbe1.tar.xz
python/holidays: Updated for version 0.40.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/holidays/holidays.SlackBuild16
-rw-r--r--python/holidays/holidays.info8
2 files changed, 13 insertions, 11 deletions
diff --git a/python/holidays/holidays.SlackBuild b/python/holidays/holidays.SlackBuild
index 93b7b260a18e..67a3a68e9ebf 100644
--- a/python/holidays/holidays.SlackBuild
+++ b/python/holidays/holidays.SlackBuild
@@ -25,9 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=holidays
-SRCNAM=python-holidays
-VERSION=${VERSION:-0.20}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.40}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,9 +69,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-v.$VERSION
-tar xvf $CWD/$SRCNAM-v.$VERSION.tar.gz
-cd $SRCNAM-v.$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,7 +79,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/holidays/holidays.info b/python/holidays/holidays.info
index c2731950ccc6..d07a728c900b 100644
--- a/python/holidays/holidays.info
+++ b/python/holidays/holidays.info
@@ -1,10 +1,10 @@
PRGNAM="holidays"
-VERSION="0.20"
+VERSION="0.40"
HOMEPAGE="https://github.com/dr-prodigy/python-holidays/"
-DOWNLOAD="https://github.com/dr-prodigy/python-holidays/archive/v.0.20/python-holidays-v.0.20.tar.gz"
-MD5SUM="9b603ffaf177d25f8084db4c212d5033"
+DOWNLOAD="https://files.pythonhosted.org/packages/01/1f/51f40218f958af28d110675285a24f32220fba89aaedd64b0ac3c95d1685/holidays-0.40.tar.gz"
+MD5SUM="859209ee527d82142c8cc10d4ddb929f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="hijri-converter PyMeeus convertdate korean_lunar_calendar"
+REQUIRES="python3-build python3-installer python3-wheel hijri-converter PyMeeus convertdate korean_lunar_calendar"
MAINTAINER="Tonus"
EMAIL="tonus1@free.fr"