aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2024-05-16 19:09:06 +0300
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-18 06:55:45 +0700
commitb149d8dd8d93e6737663c2761b6b702b0243a367 (patch)
tree0aae4b43007e552763f8a3390bc7de5bd80884f5 /python
parentc5e87865bc47566aa01c1d4fa8e442b2616c096b (diff)
downloadslackbuilds-b149d8dd8d93e6737663c2761b6b702b0243a367.tar.xz
python/virtualenvwrapper: Removed unused.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/virtualenvwrapper/README7
-rw-r--r--python/virtualenvwrapper/slack-desc19
-rw-r--r--python/virtualenvwrapper/virtualenvwrapper.SlackBuild96
-rw-r--r--python/virtualenvwrapper/virtualenvwrapper.info10
4 files changed, 0 insertions, 132 deletions
diff --git a/python/virtualenvwrapper/README b/python/virtualenvwrapper/README
deleted file mode 100644
index eaa14406fe..0000000000
--- a/python/virtualenvwrapper/README
+++ /dev/null
@@ -1,7 +0,0 @@
-virtualenvwrapper is a set of extensions to Ian Bicking's virtualenv
-tool for creating isolated Python development environments.
-
-The extensions include wrappers for creating and deleting virtual
-environments and otherwise managing your development workflow,
-making it easier to work on more than one project at a time without
-introducing conflicts in their dependencies.
diff --git a/python/virtualenvwrapper/slack-desc b/python/virtualenvwrapper/slack-desc
deleted file mode 100644
index 9270cd52bc..0000000000
--- a/python/virtualenvwrapper/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-virtualenvwrapper: virtualenvwrapper (Extensions to Ian Bicking's virtualenv tool)
-virtualenvwrapper:
-virtualenvwrapper: virtualenvwrapper is a set of extensions to Ian Bicking's virtualenv
-virtualenvwrapper: tool for creating isolated Python development environments.
-virtualenvwrapper:
-virtualenvwrapper: The extensions include wrappers for creating and deleting virtual
-virtualenvwrapper: environments and otherwise managing your development workflow,
-virtualenvwrapper: making it easier to work on more than one project at a time without
-virtualenvwrapper: introducing conflicts in their dependencies.
-virtualenvwrapper:
-virtualenvwrapper: Homepage: http://www.doughellmann.com/projects/virtualenvwrapper/
diff --git a/python/virtualenvwrapper/virtualenvwrapper.SlackBuild b/python/virtualenvwrapper/virtualenvwrapper.SlackBuild
deleted file mode 100644
index e7f9e77abd..0000000000
--- a/python/virtualenvwrapper/virtualenvwrapper.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for virtualenvwrapper
-
-# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
-# Copyright <2013> <vvoody> <Shanghai>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=virtualenvwrapper
-VERSION=${VERSION:-4.8.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/virtualenvwrapper/virtualenvwrapper.info b/python/virtualenvwrapper/virtualenvwrapper.info
deleted file mode 100644
index 2db739f734..0000000000
--- a/python/virtualenvwrapper/virtualenvwrapper.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="virtualenvwrapper"
-VERSION="4.8.4"
-HOMEPAGE="http://www.doughellmann.com/projects/virtualenvwrapper/"
-DOWNLOAD="https://files.pythonhosted.org/packages/c1/6b/2f05d73b2d2f2410b48b90d3783a0034c26afa534a4a95ad5f1178d61191/virtualenvwrapper-4.8.4.tar.gz"
-MD5SUM="b257b16b593eabd7e809cc76e63c295f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="virtualenv virtualenv-clone stevedore"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"