aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2024-11-19 18:43:14 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-23 10:50:46 +0700
commit9f40deb7d40a81b2c1567d077c7b01ec7d1113bd (patch)
tree411bff8a55ace254499ec84e978d0cb7fe447f83 /python
parent4a911d507f1127485c4a143b49d1ead28d2bde8e (diff)
python/python3-glances: Updated for version 4.2.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-glances/python3-glances.SlackBuild7
-rw-r--r--python/python3-glances/python3-glances.info6
2 files changed, 8 insertions, 5 deletions
diff --git a/python/python3-glances/python3-glances.SlackBuild b/python/python3-glances/python3-glances.SlackBuild
index 5d595b0490b37..f322d267d289b 100644
--- a/python/python3-glances/python3-glances.SlackBuild
+++ b/python/python3-glances/python3-glances.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-glances
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-4.1.2}
+VERSION=${VERSION:-4.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,7 +66,10 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
#change location to install man pages
-sed -i 's|share/man|man|g' setup.py
+sed -i 's|share/man|man|g' pyproject.toml
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl
diff --git a/python/python3-glances/python3-glances.info b/python/python3-glances/python3-glances.info
index a1ebcc67e7754..94124d060c6b7 100644
--- a/python/python3-glances/python3-glances.info
+++ b/python/python3-glances/python3-glances.info
@@ -1,8 +1,8 @@
PRGNAM="python3-glances"
-VERSION="4.1.2"
+VERSION="4.2.1"
HOMEPAGE="https://github.com/nicolargo/glances"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/g/glances/glances-4.1.2.tar.gz"
-MD5SUM="57d5338f5e5e5cb2bdf22a801132559e"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/g/glances/glances-4.2.1.tar.gz"
+MD5SUM="8958f140643c9d2e4b480e825a094907"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-psutil python3-defusedxml python3-orjson python3-netifaces python3-pymdstat python3-py-cpuinfo"