aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2022-03-08 20:19:41 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:36:27 +0700
commit9a9964d19d161cf72df17316790e821f55056884 (patch)
tree1ddc1fe54fd85562934b459f2f291d33c5ba0b67 /python
parent9ce37db212d37691272b60a77554e8d7e9a97a18 (diff)
python/python3-celery: renamed from celery for python3, updated for version 5.2.3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/celery/celery.info10
-rw-r--r--python/python3-celery/README (renamed from python/celery/README)0
-rw-r--r--python/python3-celery/python3-celery.SlackBuild (renamed from python/celery/celery.SlackBuild)14
-rw-r--r--python/python3-celery/python3-celery.info10
-rw-r--r--python/python3-celery/slack-desc (renamed from python/celery/slack-desc)24
-rw-r--r--python/python3-celery/versions.patch22
6 files changed, 52 insertions, 28 deletions
diff --git a/python/celery/celery.info b/python/celery/celery.info
deleted file mode 100644
index 7a0e09c0f36c..000000000000
--- a/python/celery/celery.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="celery"
-VERSION="3.1.26.post2"
-HOMEPAGE="http://celeryproject.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/c/celery/celery-3.1.26.post2.tar.gz"
-MD5SUM="a16881249d81591cdf5ce0dfb092ea80"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pytz kombu billiard"
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/celery/README b/python/python3-celery/README
index 6bc0f2811213..6bc0f2811213 100644
--- a/python/celery/README
+++ b/python/python3-celery/README
diff --git a/python/celery/celery.SlackBuild b/python/python3-celery/python3-celery.SlackBuild
index 9e0734b3ef99..8e46883ad2e8 100644
--- a/python/celery/celery.SlackBuild
+++ b/python/python3-celery/python3-celery.SlackBuild
@@ -22,8 +22,9 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=celery
-VERSION=${VERSION:-3.1.26.post2}
+PRGNAM=python3-celery
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-5.2.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -53,9 +54,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -63,7 +64,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+cat $CWD/versions.patch | patch -p1 || exit 1
+
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/python3-celery/python3-celery.info b/python/python3-celery/python3-celery.info
new file mode 100644
index 000000000000..5e110383b779
--- /dev/null
+++ b/python/python3-celery/python3-celery.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-celery"
+VERSION="5.2.3"
+HOMEPAGE="https://docs.celeryproject.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/c/celery/celery-5.2.3.tar.gz"
+MD5SUM="fe86cb01c4fe26c3b2b6cc9a83939af3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-kombu python3-billiard python3-prompt_toolkit pytz click click-didyoumean click-plugins click-repl"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/celery/slack-desc b/python/python3-celery/slack-desc
index 0140c472a084..785640802829 100644
--- a/python/celery/slack-desc
+++ b/python/python3-celery/slack-desc
@@ -5,15 +5,15 @@
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler------------------------------------------------------|
-celery: celery (Distributed Task Queue)
-celery:
-celery: Task queues are used as a mechanism to distribute work across threads
-celery: or machines.
-celery:
-celery:
-celery:
-celery:
-celery:
-celery:
-celery:
+ |-----handy-ruler------------------------------------------------------|
+python3-celery: python3-celery (Distributed Task Queue)
+python3-celery:
+python3-celery: Task queues are used as a mechanism to distribute work across threads
+python3-celery: or machines.
+python3-celery:
+python3-celery:
+python3-celery:
+python3-celery:
+python3-celery:
+python3-celery:
+python3-celery:
diff --git a/python/python3-celery/versions.patch b/python/python3-celery/versions.patch
new file mode 100644
index 000000000000..40538f9a0dda
--- /dev/null
+++ b/python/python3-celery/versions.patch
@@ -0,0 +1,22 @@
+diff -c a/requirements/default.txt b/requirements/default.txt
+*** a/requirements/default.txt 2022-03-04 23:38:27.302040098 +0100
+--- b/requirements/default.txt 2022-03-04 23:38:51.109040631 +0100
+***************
+*** 2,9 ****
+ billiard>=3.6.4.0,<4.0
+ kombu>=5.2.3,<6.0
+ vine>=5.0.0,<6.0
+! click>=8.0.3,<9.0
+ click-didyoumean>=0.0.3
+! click-repl>=0.2.0
+ click-plugins>=1.1.1
+! setuptools>=59.1.1,<59.7.0
+--- 2,9 ----
+ billiard>=3.6.4.0,<4.0
+ kombu>=5.2.3,<6.0
+ vine>=5.0.0,<6.0
+! click<9.0
+ click-didyoumean>=0.0.3
+! click-repl>=0.1.6
+ click-plugins>=1.1.1
+! setuptools<59.7.0