aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2022-03-08 22:06:21 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:41:09 +0700
commit5bcf2801eff053d2f38f39c0730cbcf73cae7605 (patch)
tree878077686399dc648b2c14fc28fed0acd2385535 /python
parent06cf37d60ef5b90995c6bd7d9166de56d3b7e073 (diff)
python/python3-bcrypt: renamed from bcrypt for python3, updated for version 3.2.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/Flask-Bcrypt/Flask-Bcrypt.info2
-rw-r--r--python/python3-bcrypt/README (renamed from python/bcrypt/README)0
-rw-r--r--python/python3-bcrypt/python3-bcrypt.SlackBuild (renamed from python/bcrypt/bcrypt.SlackBuild)14
-rw-r--r--python/python3-bcrypt/python3-bcrypt.info (renamed from python/bcrypt/bcrypt.info)10
-rw-r--r--python/python3-bcrypt/slack-desc (renamed from python/bcrypt/slack-desc)24
5 files changed, 25 insertions, 25 deletions
diff --git a/python/Flask-Bcrypt/Flask-Bcrypt.info b/python/Flask-Bcrypt/Flask-Bcrypt.info
index 29ccf87c3d64..e6992568680a 100644
--- a/python/Flask-Bcrypt/Flask-Bcrypt.info
+++ b/python/Flask-Bcrypt/Flask-Bcrypt.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/1d/c0/6d4c04d007d72b355de24e7a
MD5SUM="d345c36ac6637d3ca9fa942e238d00ca"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Flask bcrypt"
+REQUIRES="Flask python3-bcrypt"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/bcrypt/README b/python/python3-bcrypt/README
index f7692c8759a5..f7692c8759a5 100644
--- a/python/bcrypt/README
+++ b/python/python3-bcrypt/README
diff --git a/python/bcrypt/bcrypt.SlackBuild b/python/python3-bcrypt/python3-bcrypt.SlackBuild
index 650f4002b9c3..51299e394095 100644
--- a/python/bcrypt/bcrypt.SlackBuild
+++ b/python/python3-bcrypt/python3-bcrypt.SlackBuild
@@ -22,9 +22,10 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=bcrypt
-VERSION=${VERSION:-3.1.7}
-BUILD=${BUILD:-2}
+PRGNAM=python3-bcrypt
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-3.2.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -53,9 +54,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -63,7 +64,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/bcrypt/bcrypt.info b/python/python3-bcrypt/python3-bcrypt.info
index 3539f6c44013..bb3b71f54b7e 100644
--- a/python/bcrypt/bcrypt.info
+++ b/python/python3-bcrypt/python3-bcrypt.info
@@ -1,10 +1,10 @@
-PRGNAM="bcrypt"
-VERSION="3.1.7"
+PRGNAM="python3-bcrypt"
+VERSION="3.2.0"
HOMEPAGE="https://github.com/pyca/bcrypt/"
-DOWNLOAD="https://pypi.python.org/packages/source/b/bcrypt/bcrypt-3.1.7.tar.gz"
-MD5SUM="5d6f93b575ce52470af37a8e7dce76fe"
+DOWNLOAD="https://pypi.python.org/packages/source/b/bcrypt/bcrypt-3.2.0.tar.gz"
+MD5SUM="fe31390dab603728f756cd3d6830c80a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="cffi"
+REQUIRES=""
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"
diff --git a/python/bcrypt/slack-desc b/python/python3-bcrypt/slack-desc
index c83f12ba22d0..94daa45933e6 100644
--- a/python/bcrypt/slack-desc
+++ b/python/python3-bcrypt/slack-desc
@@ -5,15 +5,15 @@
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler------------------------------------------------------|
-bcrypt: bcrypt (password hashing)
-bcrypt:
-bcrypt: Modern(-ish) password hashing for your software and your servers
-bcrypt:
-bcrypt:
-bcrypt:
-bcrypt:
-bcrypt:
-bcrypt:
-bcrypt:
-bcrypt:
+ |-----handy-ruler------------------------------------------------------|
+python3-bcrypt: python3-bcrypt (password hashing)
+python3-bcrypt:
+python3-bcrypt: Modern(-ish) password hashing for your software and your servers
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt: