aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorYth - Arnaud <yth@ythogtha.org>2023-11-09 19:08:46 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-11 08:07:51 +0700
commit16ef4148268e5e7c5b021a4b74d9c6003ee5f763 (patch)
tree6432b7e5897aea3f3b443ae11fb4edfb9f9843be /python
parente21aab0cadcc7f5efef7f8930f92e1ba3c3c3140 (diff)
python/python3-bleach: Added (whitelist-based HTML-sanitizing tool).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-bleach/README11
-rw-r--r--python/python3-bleach/python3-bleach.SlackBuild79
-rw-r--r--python/python3-bleach/python3-bleach.info10
-rw-r--r--python/python3-bleach/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/python3-bleach/README b/python/python3-bleach/README
new file mode 100644
index 000000000000..d9d63687ea4a
--- /dev/null
+++ b/python/python3-bleach/README
@@ -0,0 +1,11 @@
+Bleach is a whitelist-based HTML sanitizing library that escapes or
+strips markup and attributes.
+
+Bleach can also linkify text safely, applying filters that Django's
+urlize filter cannot, and optionally setting rel attributes, even on
+links already in the text.
+
+Bleach is intended for sanitizing text from untrusted sources. If you
+find yourself jumping through hoops to allow your site administrators
+to do lots of things, you're probably outside the use cases. Either
+trust those users, or don't.
diff --git a/python/python3-bleach/python3-bleach.SlackBuild b/python/python3-bleach/python3-bleach.SlackBuild
new file mode 100644
index 000000000000..81fd2b68979b
--- /dev/null
+++ b/python/python3-bleach/python3-bleach.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/bash
+
+# Slackware build script for python3-bleach
+
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-bleach
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-6.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES CONTRIBUTORS README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-bleach/python3-bleach.info b/python/python3-bleach/python3-bleach.info
new file mode 100644
index 000000000000..a9d546adb028
--- /dev/null
+++ b/python/python3-bleach/python3-bleach.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-bleach"
+VERSION="6.1.0"
+HOMEPAGE="https://pypi.org/project/bleach/"
+DOWNLOAD="https://pypi.python.org/packages/source/b/bleach/bleach-6.1.0.tar.gz"
+MD5SUM="fc95673643f4e0e81f443cb15fc15937"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-webencodings"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-bleach/slack-desc b/python/python3-bleach/slack-desc
new file mode 100644
index 000000000000..98e804a8ae09
--- /dev/null
+++ b/python/python3-bleach/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-bleach: python3-bleach (whitelist-based HTML-sanitizing tool)
+python3-bleach:
+python3-bleach: Bleach is a whitelist-based HTML sanitizing library that escapes or
+python3-bleach: strips markup and attributes.
+python3-bleach:
+python3-bleach:
+python3-bleach:
+python3-bleach:
+python3-bleach:
+python3-bleach:
+python3-bleach: