aboutsummaryrefslogtreecommitdiff
path: root/python/thonny/thonny.SlackBuild
diff options
context:
space:
mode:
authorTim Dickson <dickson.tim@googlemail.com>2023-06-17 09:25:31 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-17 09:45:17 +0700
commitb34f0d7bab6f2c285c5c7d51d16072782d201890 (patch)
treeb05ad4ae8cd0492764e97a458b6e0110e609de42 /python/thonny/thonny.SlackBuild
parent388a776764da128e5b6ffed08886cb8fb825a1c6 (diff)
downloadslackbuilds-b34f0d7bab6f2c285c5c7d51d16072782d201890.tar.xz
python/thonny: Updated for version 4.1.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/thonny/thonny.SlackBuild')
-rw-r--r--python/thonny/thonny.SlackBuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/python/thonny/thonny.SlackBuild b/python/thonny/thonny.SlackBuild
index 91312f23738d..d0302163aa5c 100644
--- a/python/thonny/thonny.SlackBuild
+++ b/python/thonny/thonny.SlackBuild
@@ -27,13 +27,14 @@
#4.0.0 23 Aug 2022. version bump
#4.0.1 14 Sep 2022. version bump
#4.0.2 20 Jan 2023. version bump
-#4.1.0 7 Jul 2023. version bump
+#4.1.0 7 Jun 2023. version bump
+#4.1.1 16 Jun 2023. version bump
#note. get download link from https://pypi.org/project/thonny/#files
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=thonny
-VERSION=${VERSION:-4.1.0}
+VERSION=${VERSION:-4.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,9 +79,11 @@ find -L . \
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/share/applications
cp -a packaging/linux/org.thonny.Thonny.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-mkdir -p $PKG/usr/share/pixmaps
-cp -a packaging/icons/$PRGNAM-*.png $PKG/usr/share/pixmaps/
-cp -a packaging/icons/$PRGNAM-128x128.png $PKG/usr/share/pixmaps/$PRGNAM.png
+mkdir -p $PKG/usr/share/icons/hicolor/{16x16,22x22,32x32,48x48,64x64,128x128,192x192,256x256}/apps
+for i in `ls packaging/icons/$PRGNAM-*x*.png`; do
+ IDIR=`echo $i|awk -F"-" '{print $2}'|awk -F"." '{print $1}'`
+ cp -a $i $PKG/usr/share/icons/hicolor/$IDIR/apps/$PRGNAM.png
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
for i in CREDITS.rst README.rst CHANGELOG.rst LICENSE.txt; do
cp $i $PKG/usr/doc/$PRGNAM-$VERSION