aboutsummaryrefslogtreecommitdiff
path: root/python/python3-websockets/python3-websockets.SlackBuild
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2024-05-16 20:01:04 +0300
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-18 06:55:46 +0700
commitb3c342b4c424ff3694156984d89afc40899ef9a4 (patch)
treed354907504d1a743b3b8af8e6d018d93e42f0d53 /python/python3-websockets/python3-websockets.SlackBuild
parent00e33c32b177a42ce80e56d738c73490a0f123ae (diff)
python/python3-websockets: Updated for version 12.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-websockets/python3-websockets.SlackBuild')
-rw-r--r--python/python3-websockets/python3-websockets.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/python3-websockets/python3-websockets.SlackBuild b/python/python3-websockets/python3-websockets.SlackBuild
index 70b73ee9b0..3be3cf0018 100644
--- a/python/python3-websockets/python3-websockets.SlackBuild
+++ b/python/python3-websockets/python3-websockets.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-websockets
-# Copyright 2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2022-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-websockets
SRCNAM=websockets
-VERSION=${VERSION:-10.2}
+VERSION=${VERSION:-12.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true