aboutsummaryrefslogtreecommitdiff
path: root/python/python3-sqlobject
diff options
context:
space:
mode:
authorLockywolf <for_sbo.python3-sqlobject_2023-09-22@lockywolf.net>2023-09-23 10:11:03 +0900
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-23 11:33:34 +0700
commitc9700ab72c6584766b5a92fafa5dd6c747062fce (patch)
treecc4313324ab0596e8d2fde81744d4a0081fcc82f /python/python3-sqlobject
parent5997956445e0bbc0bc1f246c207182c6d4a339c2 (diff)
downloadslackbuilds-c9700ab72c6584766b5a92fafa5dd6c747062fce.tar.xz
python/python3-sqlobject: Added (python orm).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-sqlobject')
-rw-r--r--python/python3-sqlobject/README16
-rw-r--r--python/python3-sqlobject/python3-sqlobject.SlackBuild79
-rw-r--r--python/python3-sqlobject/python3-sqlobject.info10
-rw-r--r--python/python3-sqlobject/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/python3-sqlobject/README b/python/python3-sqlobject/README
new file mode 100644
index 000000000000..c6d3a9020968
--- /dev/null
+++ b/python/python3-sqlobject/README
@@ -0,0 +1,16 @@
+SQLObject is a popular Object Relational Manager for providing an
+object interface to your database, with tables as classes, rows as
+instances, and columns as attributes. SQLObject includes a
+Python-object-based query language that makes SQL more abstract, and
+provides substantial database independence for applications.
+
+Supports MySQL, PostgreSQL, SQLite, Firebird, Sybase, MSSQL and MaxDB
+(SAPDB).
+
+NOTE: SQLObject checks for supported databases at run time. You can
+use the MySQL-python and psycopg2 (MySQL and PostrgreSQL support,
+respectively) optional dependencies. For SQLite, SQLObject can
+use the standard Python module sqlite3, or an externally installed
+PySQLite2. For the rest, check the SQLObject documentation for links.
+
+This build is for the python3 version.
diff --git a/python/python3-sqlobject/python3-sqlobject.SlackBuild b/python/python3-sqlobject/python3-sqlobject.SlackBuild
new file mode 100644
index 000000000000..2e7758421b55
--- /dev/null
+++ b/python/python3-sqlobject/python3-sqlobject.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/bash
+
+# Slackware build script for python3-sqlobject
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-sqlobject
+TARNAM=SQLObject
+VERSION=${VERSION:-3.10.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} + -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} +
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a ANNOUNCE.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-sqlobject/python3-sqlobject.info b/python/python3-sqlobject/python3-sqlobject.info
new file mode 100644
index 000000000000..87e49c739bcf
--- /dev/null
+++ b/python/python3-sqlobject/python3-sqlobject.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-sqlobject"
+VERSION="3.10.2"
+HOMEPAGE="https://pypi.python.org/pypi/SQLObject/"
+DOWNLOAD="https://files.pythonhosted.org/packages/26/8b/b329e3bf9195b5515d1c1578a9f72f4724709f563b77c1d1128de45e8091/SQLObject-3.10.2.tar.gz"
+MD5SUM="029d4571bec55165563f44fd3e41fb18"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-formencode"
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-sqlobject_2023-09-22@lockywolf.net"
diff --git a/python/python3-sqlobject/slack-desc b/python/python3-sqlobject/slack-desc
new file mode 100644
index 000000000000..bb1b152a2b9a
--- /dev/null
+++ b/python/python3-sqlobject/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-sqlobject: python3-sqlobject (Object-Relational Manager, aka database wrapper)
+python3-sqlobject:
+python3-sqlobject: python3-sqlobject is an Object Relational Manager for providing an
+python3-sqlobject: object interface to your database, with tables as classes, rows as
+python3-sqlobject: instances, and columns as attributes. python3-sqlobject includes a
+python3-sqlobject: Python-object-based query language that makes SQL more abstract, and
+python3-sqlobject: provides substantial database independence for applications.
+python3-sqlobject:
+python3-sqlobject: https://pypi.python.org/pypi/SQLObject/
+python3-sqlobject: This build is for the python3 version.
+python3-sqlobject: