aboutsummaryrefslogtreecommitdiff
path: root/python/python3-pubsub
diff options
context:
space:
mode:
authorGianluca Pernigotto <jeanlucperni@gmail.com>2022-06-01 13:50:52 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-06-04 10:37:10 +0700
commit528afbdbc73d8572bd3395d0bd9bbc06523131a3 (patch)
treeba62460bc69007a15062d9394ead16706bd3836f /python/python3-pubsub
parent93670f588ec08e7acedb281f3e0e7ec7db9870bd (diff)
downloadslackbuilds-528afbdbc73d8572bd3395d0bd9bbc06523131a3.tar.xz
python/python3-pubsub: Added (A Python publish-subcribe library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-pubsub')
-rw-r--r--python/python3-pubsub/README8
-rw-r--r--python/python3-pubsub/python3-pubsub.SlackBuild97
-rw-r--r--python/python3-pubsub/python3-pubsub.info10
-rw-r--r--python/python3-pubsub/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/python/python3-pubsub/README b/python/python3-pubsub/README
new file mode 100644
index 000000000000..8714a23ea41b
--- /dev/null
+++ b/python/python3-pubsub/README
@@ -0,0 +1,8 @@
+PyPubSub provides a publish-subscribe API to facilitate event-based or
+message-based architecture in a single-process application. It is pure
+Python and works on Python 3.3+. It is centered on the notion of a
+topic; senders publish messages of a given topic, and listeners
+subscribe to messages of a given topic, all inside the same process.
+The package also supports a variety of advanced features that
+facilitate debugging and maintaining topics and messages in larger
+desktop-based or server-based applications.
diff --git a/python/python3-pubsub/python3-pubsub.SlackBuild b/python/python3-pubsub/python3-pubsub.SlackBuild
new file mode 100644
index 000000000000..8fdd558e0213
--- /dev/null
+++ b/python/python3-pubsub/python3-pubsub.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/bash
+
+# Slackware build script for python3-pypubsub
+
+# Copyright 2022 Gianluca Pernigotto Verona, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pubsub
+VERSION=${VERSION:-4.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=pypubsub
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst README_WxPython.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pubsub/python3-pubsub.info b/python/python3-pubsub/python3-pubsub.info
new file mode 100644
index 000000000000..325571be284a
--- /dev/null
+++ b/python/python3-pubsub/python3-pubsub.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pubsub"
+VERSION="4.0.3"
+HOMEPAGE="https://github.com/schollii/pypubsub"
+DOWNLOAD="https://github.com/schollii/pypubsub/archive/v4.0.3/pypubsub-4.0.3.tar.gz"
+MD5SUM="42d8eff087a055b76534e72e0f1f170b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Gianluca Pernigotto"
+EMAIL="jeanlucperni@gmail.com"
diff --git a/python/python3-pubsub/slack-desc b/python/python3-pubsub/slack-desc
new file mode 100644
index 000000000000..fb1651eb3d90
--- /dev/null
+++ b/python/python3-pubsub/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pubsub: python3-pubsub (A Python publish-subcribe library)
+python3-pubsub:
+python3-pubsub: PyPubSub provides a publish-subscribe API to facilitate event-based
+python3-pubsub: or message-based architecture in a single-process application.
+python3-pubsub: It is pure Python and works on Python 3.3+
+python3-pubsub:
+python3-pubsub: Homepage: https://github.com/schollii/pypubsub
+python3-pubsub:
+python3-pubsub:
+python3-pubsub:
+python3-pubsub: