aboutsummaryrefslogtreecommitdiff
path: root/python/python3-plotly/python3-plotly.SlackBuild
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu@protonmail.com>2025-04-23 23:34:31 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2025-04-24 00:56:05 +0700
commit80417421de07e442573d1c24c344f137ec63e82c (patch)
tree56783c31ea8c35ae1adf12f1cbd111f4906dc64f /python/python3-plotly/python3-plotly.SlackBuild
parent0642e46418ea5297eca5874b2506374ae979bbd6 (diff)
python/python3-plotly: Updated for version 6.0.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-plotly/python3-plotly.SlackBuild')
-rw-r--r--python/python3-plotly/python3-plotly.SlackBuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/python/python3-plotly/python3-plotly.SlackBuild b/python/python3-plotly/python3-plotly.SlackBuild
index 10867df4d3..fd2706caba 100644
--- a/python/python3-plotly/python3-plotly.SlackBuild
+++ b/python/python3-plotly/python3-plotly.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-plotly
-# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2024-2025 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-plotly
-VERSION=${VERSION:-5.24.1}
+VERSION=${VERSION:-6.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -64,19 +64,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-cd packages/python/plotly
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
-# Fix /etc/jupyter patch
-sed 's|etc|/etc|' -i setup.py
-
-# Disable npm modules while installing plotly
-SKIP_NPM=1 python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -Dm644 LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md MIGRATION_GUIDE.md README.md RELEASE.md SECURITY.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install